Bug 105406 - Slow performance of Calc with autofilter set and input search element
Summary: Slow performance of Calc with autofilter set and input search element
Status: RESOLVED DUPLICATE of bug 122419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-18 09:13 UTC by mcshel
Modified: 2020-11-08 07:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mcshel 2017-01-18 09:13:12 UTC
Description:
Open document with 21735 rows.

AutoFilter on column with a large number of diffrent data.
Opening filter list all display but input search element first symbol and Libreoffice it began to work slow, not refreshing in the display. After 50-100s all good, input second symbol and again it began to work slow.

If I use standart filter Or Autofilter on column with less diffrent data all work fast. On MS Excel all work fast.



Steps to Reproduce:
1. Open document with ~21735 rows
2. Apply Autofilter on column with diffrent data
3. Open drop-down menu Autofilter and input symbols in search elements
4. After each symbol LibreOffice slow

Actual Results:  
After each symbol LibreOffice slow filter autofilter list

Expected Results:
Work fast and filter after input each filter


Reproducible: Always

User Profile Reset: No

Additional Info:
Intel(R) Pentium(R) CPU G3240 @ 3.10GHz 2 Core
MemTotal:        3945044 kB


User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 m.a.riosv 2017-01-18 13:00:11 UTC

*** This bug has been marked as a duplicate of bug 102927 ***
Comment 2 Andres DG 2017-06-14 14:58:46 UTC
A mi me pasa lo mismo. Tengo un archivo con más de 20000 filas y 7 columnas (una sola columna es de tipo Texto) y al intentar aplicar el Autofiltro en la columna de tipo texto comienza a funcionar lento (muy lento). Esto me pasó tanto en la Versión 4.3.3.2 en Debian 8 y la Versión 5.3.2.2 en Windows.

Muchas Gracias.
Comment 3 Xisco Faulí 2017-10-27 10:59:10 UTC

*** This bug has been marked as a duplicate of bug 76481 ***
Comment 4 Kevin Suo 2020-11-08 07:23:54 UTC
Mark as a duplicate of bug 122419 instead, see my comment in:
bug 76481#c31

*** This bug has been marked as a duplicate of bug 122419 ***