Bug Hunting Session
Bug 105418 - Middle mouse click scroll does not work in Draw
Summary: Middle mouse click scroll does not work in Draw
Status: RESOLVED DUPLICATE of bug 66410
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-18 16:56 UTC by dfraipont
Modified: 2018-02-15 20:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dfraipont 2017-01-18 16:56:46 UTC
Description:
When a page is zoomed in, we have to use scroll bar to pan view.
Using middle mouse button could be easier.

Actual Results:  
 

Expected Results:
 


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Samuel Mehrbrodt (CIB) 2017-01-19 13:27:23 UTC
There is a setting for that in Tools->Options->View.
Comment 2 dfraipont 2017-01-19 16:24:28 UTC
So there is a real bug as it doesn't work in Draw, only on Writer and Calc.
Neither for "Automatic scrolling" nor "Paste clipboard"
Comment 3 Xisco Faulí 2017-06-26 18:12:10 UTC Comment hidden (obsolete)
Comment 4 dfraipont 2017-06-29 15:45:45 UTC
How to reproduce:

Open a document in Draw (here a pdf file).
Zoom on it (120%)
Click on middle mouse button and move it.
Nothing happens.

Open a document in Writer.
Do the same.
When you click on middle mouse button,
an icon with four triangles appears.
If you move the mouse pan is done.
Comment 5 Buovjaga 2017-06-29 19:48:33 UTC
Reproduced with Draw. I guess we can set it to a bug. In Linux at least I need to use "No function" to get the scrolling in Writer.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 98befbb26217b0bf3f35354e418a355280c52cfc
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 29th 2017

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 Bruce B 2017-08-27 08:41:26 UTC
(In reply to dfraipont from comment #2)
> So there is a real bug as it doesn't work in Draw, only on Writer and Calc.
> Neither for "Automatic scrolling" nor "Paste clipboard"

I have the same issue when using Center wheel button to paste in Writer. This goes for a native install Debian package .deb and also flatpak for Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 Camaleón 2017-09-01 13:45:35 UTC
Same here. I can't get the middle button does any action (nor panning neither paste) in none of the suite applications (writer, draw, calc...). This is LO 5.4.0.3 get it from The Document Foundation site and running Debian 7 (64 bits) and XFCE. Middle click button runs as expected (paste) in any other program in the system (firefox, mousepad, etc...).
Comment 8 Buovjaga 2018-02-15 20:24:07 UTC
Hmh, found an older report.

*** This bug has been marked as a duplicate of bug 66410 ***