Bug 105445 - Improve the label of "Export comments" checkbox (see comment 2)
Summary: Improve the label of "Export comments" checkbox (see comment 2)
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: PowerPC Windows (All)
: low trivial
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.3.0
Keywords: bisected
Depends on:
Blocks: PDF-Export-Options-Dialog
  Show dependency treegraph
 
Reported: 2017-01-20 02:06 UTC by bennetch
Modified: 2020-07-23 12:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bennetch 2017-01-20 02:06:39 UTC
Description:
When a spreadsheet has comments on cells and I try to export a PDF, deselecting the "Export comments" checkbox does not hide the comment in the exported PDF.

If I check the box, I also get an icon indicating a PDF annotation/comment, which can be viewed through my PDF viewer software; I suppose this is the expected behavior (aside from the fact that the comment is also rendered as above). What I'm trying to say is that the checkbox appears to work correctly as far as telling the PDF viewer to show an actual comment as a true annotation/comment, but some other aspect of the code is actually rendering the comment in the PDF exactly as it appears in the Calc document.

Steps to Reproduce:
1. Insert a comment to a cell
2. Make sure the comment is visible in the spreadsheet by selecting Show comment if necessary
3. Go to File->Export as PDF
4. Make sure "Export comments" is deselected
5. View the PDF

Actual Results:  
The PDF shows the comment as part of the PDF file

Expected Results:
The comment should not be shown


Reproducible: Always

User Profile Reset: No

Additional Info:
Tested with 5.1.6.2, 5.2.2.2, and 5.2.4.2 - all on Mac OS
Tested with 5.1.6.2 on Windows
Viewed with FoxIt, Mac Preview, and Adobe Reader


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Zineta 2017-01-20 13:17:08 UTC
I don't understand this could be considered as a bug, exported comment  is different from pictures of shown comment.If you don't want it in pdf just hide it in calc doc.When it's shown it can not be hidden in pdf.
Don't check box export comment and it won't be exported.If you check box it would be eported and then you can hide it or show in pdf.
Comment 2 bennetch 2017-01-20 14:41:37 UTC
With some thought, I do see your point of view, but as a user I find this completely unintuitive. It took reading your comment before I even considered that this is the intended behavior.

I'm working in Calc, and the popup yellow box is called a comment. When I'm creating an export, the box "Export comments" clearly (in my mind) refers to the hovering yellow box shown by Calc. It didn't occur to me that this meant "Convert Calc comments to PDF-style comments."

It would be much more clear if the checkbox were rephrased, perhaps something like "Export comments as PDF annotations" or maybe "Embed Calc comments as PDF annotations."

If this is the intended behavior, it would also be handy to have an additional option to "Hide Calc comments" in the PDF document, so that I can leave the comments shown when editing the document and hide them all in one mouse click when generating a PDF.

At the very, very least, please rephrase the text at the checkbox so that it is more clear that it's referring to comments as PDF annotations, not as the actual yellow boxes shown on the page.
Comment 3 Zineta 2017-01-20 21:50:25 UTC
Anyway,you can hide all comments with one mouse click selecting  all sheet and than go to menu Sheet->Cell comment->Hide comment  before export ods document  to PDF.
Comment 4 Buovjaga 2017-01-24 08:02:18 UTC
Ok, let's change the subject and set to NEW.
Comment 5 Timur 2017-01-24 13:59:30 UTC
(In reply to bennetch from comment #2)
> If this is the intended behavior, it would also be handy to have an
> additional option to "Hide Calc comments" in the PDF document, so that I can
> leave the comments shown when editing the document and hide them all in one
> mouse click when generating a PDF.
It's Bug 84837.
Speaking of comments, there's interesting Bug 77650.
Comment 6 QA Administrators 2018-01-25 03:28:30 UTC Comment hidden (obsolete)
Comment 7 Durant 2018-12-27 07:38:03 UTC Comment hidden (spam)
Comment 8 Commit Notification 2019-03-05 07:54:35 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7813c499fcae3aad9be15e4ecb0bae9a379f5d30%5E%21

tdf#105445 Change label "Export comments" to "Comments as PDF annotations"

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-03-07 14:41:01 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/0d749e887dc08a756215296e531650e97544aa92%5E%21

tdf105445 Change help
Comment 10 caroline kaylee 2019-08-30 18:52:23 UTC Comment hidden (spam)
Comment 11 Tim Nollan 2019-11-01 16:02:46 UTC Comment hidden (spam)
Comment 12 KateNill 2019-11-12 10:28:15 UTC Comment hidden (spam)
Comment 13 KateNill 2019-11-12 10:29:28 UTC Comment hidden (spam)
Comment 14 TomHoll 2019-11-20 13:48:46 UTC Comment hidden (spam)
Comment 15 adilbalti 2020-06-07 02:25:54 UTC Comment hidden (spam)