Bug 105459 - broken PDF generated ( Chrome/Acrobat Reader )
Summary: broken PDF generated ( Chrome/Acrobat Reader )
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: bibisected, bisected, filter:pdf
Depends on:
Blocks: PDF-Export-Invalid
  Show dependency treegraph
Reported: 2017-01-20 23:55 UTC by Haleh Alemasoom
Modified: 2021-09-13 08:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

original slide and generated broken pdf (681.76 KB, application/zip)
2017-01-20 23:55 UTC, Haleh Alemasoom

Note You need to log in before you can comment on or make changes to this bug.
Description Haleh Alemasoom 2017-01-20 23:55:36 UTC
Created attachment 130589 [details]
original slide and generated broken pdf

LibreOffice 4.4 (and 5.1) generates a broken PDF for the attached pptx file. 
Opening the PDF in Acrobat results in "There was an error processing a page. There was a problem reading this document (109)."
Comment 1 Xisco Faulí 2017-01-22 11:49:06 UTC
i can open the attached document with evince and firefox under linux. Probably it's only reproducible with Adobe?
Anyway, it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Haleh Alemasoom 2017-02-06 21:52:18 UTC
I tried it with latest version of LibreOffice ( and still the same problem. Yes it only happens with Adobe Acrobat Reader. It is file in firefox, ...
Comment 3 Haleh Alemasoom 2017-02-06 21:53:13 UTC
it is *fine in firefox.
Comment 4 Xisco Faulí 2017-02-10 17:37:08 UTC
Confirmed in

Build ID: a25b1ff25a3be97d688d66b12353b4217fd239a5
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and Chrome 46.0.2490.80
Comment 5 QA Administrators 2018-02-11 03:32:57 UTC Comment hidden (obsolete)
Comment 6 keter 2018-11-29 09:24:44 UTC
Version: (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded

Still exists in version (x64)
The generated broken pdf cannot be opened in Chrome/Acrobat Reader/PDF-XChange Editor/Firefox. I tried to export the original slide as another PDF in version (x64) again, and the problem still exists.
Comment 7 Timur 2020-02-06 11:54:28 UTC
Reproduced with attached PDF and with LO but not with master LO 70+ exported PDF.
Comment 8 Timur 2021-09-13 08:06:19 UTC
Fixed in 7.0 with:
Linux commit 2a24d32dc0c13567943950d0b74eeaa23f707eb3
Date:   Mon Jan 20 23:17:39 2020 +0100
    source sha:b894ec7fadb8ca6bf0b33fa9eee4b9303e8161d
    pre 77bba5b6b9f12fc0970918f5073c52775a48603c

author	Miklos Vajna <vmiklos@collabora.com>	Mon Jan 20 2020 
PDF export: skip pointless downsampling for very small images

Regression from commit b6588bd7c831ce88a29131ca7ea8d3f3e082564e (Reduce
image resolution by default in PDF Export, 2014-03-02) the problem is
that in case you have small enough bitmaps, then these used to look
OK at reasonable zoom levels, but now we intentionally scale down
bitmaps by default.
That makes little sense for tiny images, do this only for large ones.