Download it now!
Bug 105487 - Screen readers have trouble reading tables that span multiple pages
Summary: Screen readers have trouble reading tables that span multiple pages
Status: RESOLVED DUPLICATE of bug 87680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, bibisectRequest, regression
Depends on:
Blocks: a11y
  Show dependency treegraph
 
Reported: 2017-01-23 14:38 UTC by am_dxer
Modified: 2018-07-09 16:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document to demonstrate issues. (12.41 KB, application/vnd.oasis.opendocument.text)
2017-01-23 14:41 UTC, am_dxer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2017-01-23 14:38:25 UTC
Description:
When moving between Pages with the Up and "Down arrow keys, NVDA is silent when reading the first row on the new page.

Steps to Reproduce:
1. Open the attached document with a table that spans multiple pages.
2. Press the Down arrow key until NVDA announces page 2.
3. Press the Up arrow key to return focus to page 1.

Actual Results:  
For the first two presses of the Up arrow key, NVDA announces no information.

Expected Results:
NVDA should speak the text in the table that focus is on.


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Comment 1 am_dxer 2017-01-23 14:41:31 UTC
Created attachment 130630 [details]
Test document to demonstrate issues.

Test document to demonstrate issues.
Comment 2 Alex ARNAUD 2017-01-29 18:12:23 UTC
Dear all,

I can reproduce the issue with LibreOffice 5.2.4 (GTK2) on Debian 8.7 with Orca master.

Best regards.
Comment 3 am_dxer 2017-05-23 17:27:33 UTC
I can still reproduce this in LibreOffice 5.5. This is a severe a11y issue as it makes navigating tables very difficult with screen readers. I don't know if it helps any but this issue is not present in Open Office. I notice that when running NVDA Master, it makes the NVDA error sound often when navigating between pages when in a table.
Comment 4 Alex ARNAUD 2017-05-29 18:46:06 UTC
(In reply to am_dxer from comment #3)
> I can still reproduce this in LibreOffice 5.5. This is a severe a11y issue
> as it makes navigating tables very difficult with screen readers. I don't
> know if it helps any but this issue is not present in Open Office. I notice
> that when running NVDA Master, it makes the NVDA error sound often when
> navigating between pages when in a table.

The information you provide is really useful. The better thing you can do to help us to figure out this issue is to check which commit introduces this issue. To do that there is a mechanism name bibisecting.

You could find more information here : https://wiki.documentfoundation.org/QA/Bibisect

You can contact me on IRC with the nickname "alexarnaud" on Freenode (channel #libreoffice-design) if you need help or by mail.

It could be a great help if someone helps the QA team to find where the regression were introduced.

Best regards.
Comment 5 am_dxer 2017-05-30 13:16:49 UTC
Can't reproduce this one in old versions OpenOffice. I will try to bisect it.
Comment 6 am_dxer 2017-06-26 16:32:05 UTC
I can reproduce in 5.0.0.2. Must be older.
Comment 7 am_dxer 2017-06-26 17:17:21 UTC
Repro in 4.3.0.1. Must be older.
Comment 8 am_dxer 2017-06-26 19:47:45 UTC
Can't repro in 3.5.7.2. Must be newer.
Comment 9 Alex ARNAUD 2017-07-18 14:15:35 UTC
Dear all,

For the record, I can't reproduce on LibreOffice 4.2.

Best regards.
Comment 10 am_dxer 2018-07-09 16:20:51 UTC

*** This bug has been marked as a duplicate of bug 87680 ***