Bug Hunting Session
Bug 105496 - Standard Filter dialog box too big multi-display setup, unable to resize Standard Filter Dialog
Summary: Standard Filter dialog box too big multi-display setup, unable to resize Stan...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Multimonitor
  Show dependency treegraph
 
Reported: 2017-01-24 04:19 UTC by dbelya01
Modified: 2017-02-02 03:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dbelya01 2017-01-24 04:19:21 UTC
Description:
I have 3 displays attached to my PC, the Standard Filter dialog comes up spanning almost the entire with of all three displays (~80%) - the dialog is not re-sizable.

Steps to Reproduce:
1. Open From Menu: (Data -> More Filters -> Standard Filter ...)

Actual Results:  
non-re-sizable modal dialog titled "Standard Filter" is shown

Expected Results:
The dialog need not be larger then a single monitor, certainly it should not be wider than the Calc window, and there is no reason for it to be non-re-sizable, though I supposed I can see why it's modal.


Reproducible: Always

User Profile Reset: No

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes
Builds ID: LibreOffice 5.2.3.3


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Comment 1 Heiko Tietze 2017-01-31 07:48:09 UTC
(In reply to dbelya01 from comment #0)
> Builds ID: LibreOffice 5.2.3.3

In current master (5.4) the dialog is okay. Would be good to get a verification from someone else. And yes, the dialog should scale well and must not spawn multiple windows.
Comment 2 dbelya01 2017-02-01 02:43:35 UTC
I'm not sure I'd have time to dnload/compile source in the next few days.
But I had a few minutes and dnloaded 5.3.0.3 RC.
The filter box did initially come up on the wrong display, not the same as where the application was, but at least it was reasonably sized.
will update if I get around to working with the 5.4 source
Comment 3 Heiko Tietze 2017-02-01 08:22:12 UTC
(In reply to dbelya01 from comment #2)
> I'm not sure I'd have time to dnload/compile source in the next few days.

Master are nightly builds available at http://dev-builds.libreoffice.org/daily/master/ for all platforms. No need to compile from source.

"Builds ID: LibreOffice 5.2.3.3" means you run the still version, which was updated to 5.2.5 last week. We encourage every user to install the new version as it has numerous fixes. Version 5.3, the fresh version for the early adopters will be released in the next days. And master is 5.4.

Let's close this ticket as WFM. Please reopen in case you face the same error with 5.2.5 or above.
Comment 4 dbelya01 2017-02-02 03:10:13 UTC
Great!
Ok downloaded ver.:  5.4.0.0.alpha0+
from: http://dev-builds.libreoffice.org/daily/master/Win-x86@62-merge-TDF/2017-02-02_00.34.40/

can confirm that the Standard filter dialog appears on the correct monitor is is of reasonable size (still not re-sizable, but I think that's by design)

bonus: tried the same version in MacOS, I think I found a different bug, will submit separately