Bug 105504 - UI: No key-ID code shown in extended tooltip
Summary: UI: No key-ID code shown in extended tooltip
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Toolbars-Tooltips
  Show dependency treegraph
 
Reported: 2017-01-24 13:30 UTC by Cor Nouws
Modified: 2022-01-12 16:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2017-01-24 13:30:38 UTC
1) Turn extended tooltips on
   Tools > Options > LibreOffice > General
2) Select UI language Key-ID
   Tools > Options > Language settings > Language .. User Interface
   ... Restart
3) Put mouse pointer above toolbar button:
   > no key-ID shown with the text


4) Turn extended tooltips off
   Tools > Options > LibreOffice > General
5) Put mouse pointer above toolbar button:
   > key-ID shown with the text

Expected: also show key-ID with extended tooltips

Version: 5.3.0.0.alpha1+
Build ID: a6ce5d391476e4b6a2cb2d92ff45548c1d75684b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-03_23:34:51
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 1 Buovjaga 2017-01-25 17:44:08 UTC
I see the IDs.
I see you are running a fairly old build, from 2016-11-03. What about a newer build?

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 63fd4c97118a943c84ba5a666cf8c9cc54b511c7
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 22th 2016
Comment 2 Cor Nouws 2017-02-01 11:50:52 UTC
(In reply to Buovjaga from comment #1)
> I see the IDs.
> I see you are running a fairly old build, from 2016-11-03. What about a
> newer build?


GZAsH‖Version: 5.4.0.0.alpha0+
oKnh7‖Build ID: c6dd735afb2e1b3837c4f8c5659f52fafab4c56f
iEoWj‖CPU Threads: 4; GPAz8‖OS Version: Linux 4.8; Fiy4o‖UI Render: FCA6B‖default; sHx69‖VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-01-30_03:01:16
RgFjK‖Locale: nl-NL (nl_NL.UTF-8); Calc: group

Looking at formatting toolbar in Writer:

list Apply Style: no
button Refresh: yes
button New Style: yes
list fonts: no
list Font size: no
button Bold: no
etc.

On the Default toolbar:
button New: no
button Open: yes
button Save: no
...


seems to be different with old and new elements.
Comment 3 Buovjaga 2017-02-01 17:55:28 UTC
Weird. I see the KeyID for all the ones you listed, when I use Extended tips.
I even tried with GTK2, but same result.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: b12823aa81003e80372bd89db79bd6ba8e032a95
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 1st 2016
Comment 4 Cor Nouws 2017-02-01 17:59:03 UTC
(In reply to Buovjaga from comment #3)
> Weird. I see the KeyID for all the ones you listed, when I use Extended tips.
> I even tried with GTK2, but same result.

a. Can you give me the id's for some of the one's I don't have?

b. Maybe just a race conditions issue, that the stuff isn't always loaded in time?

thanks!
Comment 5 Buovjaga 2017-02-01 18:05:00 UTC
(In reply to Cor Nouws from comment #2)
> list Apply Style: no

QjBFe

> list fonts: no

fnvzQ

> list Font size: no

PpNqG

> button Bold: no

ZE4eE

> On the Default toolbar:
> button New: no

GvBYt

> button Save: no

CKWkk
Comment 6 Olivier Hallot 2017-04-06 14:33:30 UTC
Confirmed on master.
Extended tips don't carry KeyID prefixed.
Comment 7 Olivier Hallot 2022-01-12 16:33:10 UTC
Cannot confirm anymore. I see keyID in all toolbar icons.

- Closing worksforme.