Download it now!
Bug 105506 - UX: Libo will jump from the last position in the document to text cursor position when (auto)saving and the last change is made in a table cell
Summary: UX: Libo will jump from the last position in the document to text cursor posi...
Status: RESOLVED DUPLICATE of bug 41063
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-24 16:31 UTC by Telesto
Modified: 2017-01-24 17:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.13 KB, application/vnd.oasis.opendocument.text)
2017-01-24 16:32 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-01-24 16:31:00 UTC
Description:
LibO has the - annoying - habit to switch from the current position in a document to the position of the text cursor, when (auto)saving if: 
(a) the last change is made in the table cell 
(b) the text cursor isn't moved somewhere else after the change

Steps to Reproduce:
1. Open attached file 
2. Type something into the yellow table cell
3. Scroll down (so you can't see the yellow table cell); for example to page 2 in single page view with zoom factor 100%
4. Click save button or CTRL+S

Actual Results:  
LibO will jump to the position of the table cell

Expected Results:
The position in the document should be persevered. Save behavior as without a table


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: 79497f458727a0dea983847fe9d3873bf9c2e972
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-24_03:10:09
Locale: nl-NL (nl_NL); Calc: CL

and in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-01-24 16:32:25 UTC
Created attachment 130656 [details]
Example file
Comment 2 V Stuart Foote 2017-01-24 17:46:01 UTC
Clear duplicate of bug 41063 with partial fix for related bug 95797

*** This bug has been marked as a duplicate of bug 41063 ***