Bug 105544 - Manage Conditional Formatting is not able to edit a condition
Summary: Manage Conditional Formatting is not able to edit a condition
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: high normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:5.4.0 target:5.3.2 target:6.2.0
Keywords: bibisected, bisected, regression
: 105114 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2017-01-26 14:53 UTC by pajaro
Modified: 2018-09-16 19:10 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
document to reproduce bug (22.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-01-26 14:56 UTC, pajaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pajaro 2017-01-26 14:53:23 UTC
Description:
Some times formatting conditions cant be edited

Steps to Reproduce:
This happens frequently, but if you try it a second time or reopen the document it just works again. It wasnt easy to be able to reproduce it every time :)

1. Open the attached document
2. select B3. Format> conditional formating> manage
3. select B3:B37 range and click edit, then click yes


Actual Results:  
It goes back to manage conditions

Expected Results:
Editing the range


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 pajaro 2017-01-26 14:56:26 UTC
Created attachment 130701 [details]
document to reproduce bug
Comment 2 Buovjaga 2017-01-26 15:03:45 UTC
I reproduce. I already tested on Windows earlier. Version 5.0.2.2 does not ask "do you want to edit" and it goes straight to editing.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 63fd4c97118a943c84ba5a666cf8c9cc54b511c7
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 22th 2016

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.4.2.0+
Build ID: 5.2.4-2
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 3 Aron Budea 2017-01-28 07:09:25 UTC Comment hidden (bibisection)
Comment 4 Aron Budea 2017-01-28 07:11:40 UTC
Bibisect results point to the commit referenced below. Adding Cc: to Markus Mohrhard, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5b8c22379e2eae74f7ed78326ab89483db5c6624
author	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-09-18 14:14:35 (GMT)
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-09-19 10:10:09 (GMT)

"tdf#96453, tdf#100793 rework transfer of data between cond format dlgs"
Comment 5 karsten.henning 2017-01-29 09:15:33 UTC
Hallo,

it works in 5.3.0.3 better but not fine! If I want to edit conditions second time the program don't return to the list of condition. 


I will demonstrate it on the same file:

1. Open the attached document
2. select Y9. Format> conditional formating> manage
3. select C3:BA100 range and click EDIT, 
4. Answer the question with YES 
5. Now edit the conditions and click YES or CANCEL

now it returns to list of conditions

6. select C3:BA100 range again and click EDIT, 
7. Answer the question with YES 
8. Now edit the conditions and click YES or CANCEL

now it does not return to list of conditions!
Comment 6 Timur 2017-01-30 17:23:12 UTC
Aron, since Bug 96453 is still open, why would this be a new bug? 
Do you think this one may be closed as a duplicate?
Comment 7 Aron Budea 2017-01-30 20:25:58 UTC
(In reply to Timur from comment #6)
> Aron, since Bug 96453 is still open, why would this be a new bug? 
> Do you think this one may be closed as a duplicate?

Bug 96453 is a different issue, and the partial bugfix for that issue caused this one. We can't be certain finishing that fix will get rid of this bug as well, therefore it's safer that this one has its own report (and bug 105114, too).
Comment 8 Commit Notification 2017-02-18 11:13:06 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b9e33cceb635cd3c173bd1f461af98cfd6f6ed2

don't forget to set the managed flag, tdf#105544

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-03-14 18:33:58 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d9128bc895bfa9740cd85c766a10217e35aaa937&h=libreoffice-5-3

don't forget to set the managed flag, tdf#105544

It will be available in 5.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Wolf Seiboth 2017-03-23 12:58:37 UTC
I found this behavior on 5.3.1

1.)
A range (let's say A1:A7) is formatted with an condition.
Set cursor somewhere into that range and select:
>Format > Condition...
A Dialog pop's up and Tells me:
"The selected Cell already contains...."
"Do you want to edit the existing conditional formatting..."
When select "Yes" it shows me a blank dialog where I can define a new condition.
I have to remember and select the whole range of A1:A7 to access the existing conditions.

2.)
If a Document created with a previous Version of LibreOffice exist and I want to Add or Edit an a condition, the dialog as described above pop's up and ask the Question whether I wanna edit existing conditions or not.
When hitting "Yes", a list of existing conditions are shown in a list. I select one, click [Edit] and the dialog disappear and the original one with the Question whether I wanna edit existing conditions or not appears again.
... endless loop without any chance to access my entered conditions.
I have to remove all of them before I can enter an new one into the desired range.
Comment 11 Buovjaga 2017-04-10 09:25:18 UTC
*** Bug 105114 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2018-09-16 19:10:11 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae0d1f3af9ae129c3a7d98a544e0c9b0c30659c7

uitest for bug tdf#105544

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.