Bug 105552 - Print preview empty with only background color changed
Summary: Print preview empty with only background color changed
Status: RESOLVED DUPLICATE of bug 39068
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-26 16:30 UTC by ralf.krapf
Modified: 2018-03-19 19:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Empty Print Preview (98.99 KB, image/png)
2017-01-26 16:32 UTC, ralf.krapf
Details
Borders applied to whole row A (33.03 KB, image/png)
2017-03-16 14:49 UTC, Kruno
Details
Print preview after borders applied to whole row A (1.11 KB, image/png)
2017-03-16 14:51 UTC, Kruno
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ralf.krapf 2017-01-26 16:30:42 UTC
Hi

This Bug is in LO 5.2.4.2 under W7 64bit.

Steps to reproduce:
- Create a new Calc file
- Change the background color of some cells
-> Go to print preview -> shows "no data".

Have a look at the screenshots for understanding.

If you add some borders, the print preview is ok.

Cheers
Ralf

PS: this is similar to Bug 93315.
Comment 1 ralf.krapf 2017-01-26 16:32:03 UTC
Created attachment 130706 [details]
Empty Print Preview
Comment 2 Buovjaga 2017-02-02 19:25:57 UTC
Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: b12823aa81003e80372bd89db79bd6ba8e032a95
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 1st 2016

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Kruno 2017-03-16 14:46:46 UTC
It's not simple or consistent. If only top border is added to A1 - no data. If background color applied to that same cell - no data. If only top border applied to e.g. E6, print preview works. But if only background color applied to E6, print preview doesn't word.

Top row is problematic concerning background color and borders, but center of sheet only concerning background color.

That top row (A) is badly broken. If borders applied to whole row, nothing will be shown i print preview. But when some text added to sheet, borders will not be show for whole row, only first two cell will have them.

See attachment 'borders-applyied-to-whole-row' and 'print-preview-borders-applyied-to-whole-row'.

GNU/Linux, LO 5.1.6
Comment 4 Kruno 2017-03-16 14:49:26 UTC
Created attachment 131934 [details]
Borders applied to whole row A
Comment 5 Kruno 2017-03-16 14:51:30 UTC
Created attachment 131935 [details]
Print preview after borders applied to whole row A
Comment 6 Kruno 2017-03-16 14:53:48 UTC
Correction: first three cells will have borders and only after some text is added to the sheet, otherwise no data.
Comment 7 QA Administrators 2018-03-17 03:32:59 UTC Comment hidden (obsolete)
Comment 8 ralf.krapf 2018-03-18 10:25:07 UTC
Still present in LO 6.0.1.1

Cheers Ralf
Comment 9 Thomas Lendo 2018-03-19 19:14:47 UTC

*** This bug has been marked as a duplicate of bug 39068 ***