Bug Hunting Session
Bug 105560 - "View > Grid Lines for Sheet" only affects current sheet, not all selected sheets
Summary: "View > Grid Lines for Sheet" only affects current sheet, not all selected sh...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Document-Options
  Show dependency treegraph
 
Reported: 2017-01-26 21:22 UTC by Gilward Kukel
Modified: 2018-06-21 08:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilward Kukel 2017-01-26 21:22:37 UTC
Description:
"View > Grid Lines for Sheet" only affects current sheet, not all selected sheets

Steps to Reproduce:
1. select two or more sheets
2. choose View > Grid Lines for Sheet

Actual Results:  
only the current sheet is affected

Expected Results:
all selected sheets should be affected


Reproducible: Always

User Profile Reset: yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 m.a.riosv 2017-01-27 00:50:00 UTC
I can't reproduce all sheets are always affected.
Version: 5.2.5.1 (x64)
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
Locale: es-ES (es_ES); Calc: group
Comment 2 Gilward Kukel 2017-01-27 16:59:47 UTC
Did you go to the View menu and choose "Grid Lines for Sheet"? That is what I meant. Not the setting in Tools > Options > Calc > View.

Now I have tested it with 5.2.5.1. Same behaviour.
Comment 3 m.a.riosv 2017-01-27 22:08:43 UTC
Works for me on both ways:
Version: 5.2.5.1 (x64)
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
Locale: es-ES (es_ES); Calc: group

Please test disabling OpenGL
Menu/Tools/Options/LibreOffice/View
Comment 4 Gilward Kukel 2017-01-27 23:11:18 UTC
OpenGL was already disabled although the setting "Use OpenGL for all rendering" is enabled. Nothing changes when I disable that.

Version: 5.2.5.1
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default;
Comment 5 m.a.riosv 2017-01-28 22:38:35 UTC
Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 6 Gilward Kukel 2017-01-29 00:17:27 UTC
Same behaviour with a new profile and with the 64-bit version of 5.2.5.1 on Windows 7 and also with 5.1.4.2 on Linux.
Comment 7 m.a.riosv 2017-01-29 01:05:15 UTC
Changed to unconformed to let's someone else test the issue.
Comment 8 Heiko Tietze 2017-01-30 12:14:04 UTC
We have a general setting under Tools > Options > Calc > View that _hides_ grid lines for new sheets. And we have View > Grid Lines for Sheet that affects the current sheet only. It's a perfect WFM.

BTW, in bug 105326 the removal of Tools > Options > Writer > Grid Lines is requested. Calc and Writer should behave similarly.
Comment 9 Heiko Tietze 2017-01-30 12:14:39 UTC
Forgot to add the version I used to test the issue

Version: 5.4.0.0.alpha0+
Build ID: fa2eb4b43fc872c171129d477cfabe9fa29d78ce
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-18_01:17:32
Locale: de-DE (de_DE); Calc: group
Comment 10 Gilward Kukel 2017-01-30 16:19:14 UTC
I think it would be better if it affected all selected sheets.
Comment 11 Cor Nouws 2017-02-06 23:31:07 UTC
(In reply to gilward.kukel from comment #10)
> I think it would be better if it affected all selected sheets.

Maybe this suggestion makes sense.
Isn't it that when one has more sheets selected, that actions take effect on all selected sheets?
Or looking at View > Value highlighting (and others): that work on all sheets too.

Can we have some more discussion please?

(I see that in 4.4.7 the string was ~ ".. Show/hide gridlines for the current sheet")
Comment 12 Cor Nouws 2017-02-07 17:43:45 UTC
(In reply to Cor Nouws from comment #11)
> 
> Can we have some more discussion please?

Sorry for being so careful, that it was not clear: I'm in favor for making the change as Gilward suggest. Arguments given in previous comment.
Comment 13 Gilward Kukel 2017-02-07 18:09:57 UTC
If some of the selected sheets have grid lines and some don't, it should behave like that:
if the current sheet has grid lines, all selected sheets hide the grid lines;
if the current sheet has no grid lines, all selected sheets show the grid lines.
Comment 14 Heiko Tietze 2017-02-08 08:57:51 UTC
Once again my position:

We have Tools > Options for general settings. Enabling an option there should have a) an effect across all open documents/objects (sheets in this case) and b) be persistent meaning after opening another document or restarting the app this option is active. Under Menu > View or any similar place we have less persistent features. It must not be just a duplication of Tools > Options to avoid confusion and because its scope is different. Menu options are not persistent, when you restart the app your setting is reverted to what is defined in T>O.

Putting all together my position is that you either enable grid lines for the active having it off by default or you switch them on by default and off with M>V (current status WFM, more or less).

The same is true for bug 105326 where my suggestion is to keep the checkboxes in the option menu but toggle the grid lines on or off per session.
Comment 15 Cor Nouws 2017-02-08 11:23:24 UTC
Hi Heiko,

(In reply to Heiko Tietze from comment #14)

> ... Menu
> options are not persistent, when you restart the app your setting is
> reverted to what is defined in T>O.


Sure. When you've turned the grid lines off, close and open the document, the lines are shown again.
That is not related to the question if changing the visibility is done for the visible sheet, or for all selected (by tab -clicking at the bottom) sheets.
This issue is about the latter.
Comment 16 Heiko Tietze 2017-02-08 11:31:41 UTC
(In reply to Cor Nouws from comment #15)
> That is not related to the question if changing the visibility is done for
> the visible sheet, or for all selected (by tab -clicking at the bottom)
> sheets.

It's similar as affecting all sheets would behave like a general setting.
Comment 17 Cor Nouws 2017-02-08 11:45:15 UTC
(In reply to Heiko Tietze from comment #16)

> It's similar as affecting all sheets would behave like a general setting.

But not persisting and not for all sheets, just the selected ones.
Comment 18 Heiko Tietze 2017-02-08 11:48:06 UTC
(In reply to Cor Nouws from comment #17)
> But not persisting and not for all sheets, just the selected ones.

_Selected_ sheets agreed but not _all_.
Comment 19 Cor Nouws 2017-02-08 11:53:55 UTC
(In reply to Heiko Tietze from comment #18)


> _Selected_ sheets agreed but not _all_.

Thanks for being so kind to give me the opportunity to agree with you ;)
Comment 20 Gilward Kukel 2017-02-08 16:42:52 UTC
(In reply to Heiko Tietze from comment #14)
> Menu options are not persistent, when you restart the app your setting is
> reverted to what is defined in T>O.

That's not true. When you hide the grid lines through the menu and save and reload the document, they are still hidden. But it does not tell you that you have to save (no yellow star on the SAVE icon, no asking if you want to save when you close the document). If you don't save, the grid lines will be shown again.
Comment 21 Heiko Tietze 2017-02-08 17:13:04 UTC
Hm... in this case the settings are stored with the document (havent checked this). Take my advice as what I would understand as the general rule.
Comment 22 Heiko Tietze 2018-06-21 08:36:47 UTC
We discussed this ticket in the design session and came to the conclusion of NOTABUG. Tools > options as a general setting and view > gridlines for the current sheet is the proposed workflow and works alike at Excel.

Issues around this topic:

Bug 118292 - Setting of View > Gridlines not stored with the document (see also comment 20)
Bug 118294 - Hidden gridlines cannot made visible temporarily
Bug 118295 - Gridlines "Show on colored cells" not working
Bug 118296 - Color at tools > options > gridlines cannot be reverted