Download it now!
Bug 105593 - Writer renders table text differently (regression per Comment 6)
Summary: Writer renders table text differently (regression per Comment 6)
Status: RESOLVED DUPLICATE of bug 130494
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2017-01-29 11:43 UTC by g4827387
Modified: 2020-02-12 09:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (2.71 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-01-29 11:43 UTC, g4827387
Details
Image showing differences between LibreOffice/Word (168.68 KB, image/jpeg)
2017-01-29 11:45 UTC, g4827387
Details

Note You need to log in before you can comment on or make changes to this bug.
Description g4827387 2017-01-29 11:43:49 UTC
Created attachment 130742 [details]
Sample document

Hi,

I am not the author of this document and can't really tell how it was created, but opening the same file in the latest LibreOffice 5.3.0.3 and Word 2007 shows differences in text rendering and image placements.

A picture and the document are attached.

Thanks,
Comment 1 g4827387 2017-01-29 11:45:10 UTC
Created attachment 130743 [details]
Image showing differences between LibreOffice/Word
Comment 2 Xisco Faulí 2017-01-30 23:48:59 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: fc53cce64400430cdc21f79c959d75fb9a26d13d
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)
Comment 3 QA Administrators 2018-01-31 03:42:59 UTC Comment hidden (obsolete)
Comment 4 g4827387 2018-04-26 14:35:24 UTC
This issue is still present in version 6.0.3.2 (x64).

However, I opened this specific file in LibreOffice 3.3 and I must say compatibility with Word has drastically improved since then.
Comment 5 Timur 2020-01-24 16:22:17 UTC
I tested with LO 7.0+ and there are differences to MSO.
DOCX is 2007 but same if resaved in MSO. 
But this bug is wrong from the beginning, this is "document based" but it should be "issue based".

I see the following problems, and a single one can remain in this bug, others should be first searched for duplicates in existing bugs:

1. 2nd page text box is wrong horizontally positioned, MSO setting is "Absolute position 0cm to the right of column". Maybe a duplicate of bug 100920.

2. 2nd page fist column text is bold and it's not in MSO

3. 2nd page last column text is wrong font Arial, MSO is Trebuchet MS (Body)

4. 2nd page last sandy beach image is different position and size in LO because it's cropped in MSO and scaled to 34% and Layout in table cell, although shows 8,49 cm x 5,38 cm in both.
Comment 6 Timur 2020-01-24 16:59:04 UTC
These are old issues:
2nd page text box is wrong horizontally positioned, MSO setting is "Absolute position 0cm to the right of column". Maybe a duplicate of bug 100920 or bug 119697.
2nd page last sandy beach image is different position and size in LO because it's cropped in MSO and scaled to 34% and Layout in table cell, although shows 8,49 cm x 5,38 cm in both. Looks like size is inherited from OO, even before other content was improved and table shown.

These are new regression issues, not in 6.4.0, looks like from LO 6.5+ and I change bug to them:
2nd page fist column text is bold and it's not in MSO
2nd page last column text is wrong font Arial, MSO is Trebuchet MS (Body)
Comment 7 Xisco Faulí 2020-01-29 16:43:19 UTC
(In reply to Timur from comment #6)
> These are new regression issues, not in 6.4.0, looks like from LO 6.5+ and I
> change bug to them:
> 2nd page fist column text is bold and it's not in MSO
> 2nd page last column text is wrong font Arial, MSO is Trebuchet MS (Body)

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2ab481b038b62b1ff576ac4d49d03c1798cd7f84

author	László Németh <nemeth@numbertext.org>	2020-01-08 14:26:40 +0100
committer	László Németh <nemeth@numbertext.org>	2020-01-09 18:00:16 +0100
commit	2ab481b038b62b1ff576ac4d49d03c1798cd7f84 (patch)
tree	9739e3b799bd06ba07d8cca7ad6c8b85de75dda8
parent	79084665f0e351a3f83fdee88071919f05ec9cc3 (diff)
tdf#90069 DOCX: fix character style of new table rows

Bisected with: bibisect-linux64-6.5

Adding Cc: to László Németh
Comment 8 Xisco Faulí 2020-02-12 09:51:32 UTC
Regression fixed by https://git.libreoffice.org/core/commit/abb9c7db8bcc06f907d39a7811711882161d5803
Closing as a duplicate of bug 130494

*** This bug has been marked as a duplicate of bug 130494 ***