Bug Hunting Session
Bug 105669 - Double-clic instead of single-clic
Summary: Double-clic instead of single-clic
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Adolfo Jayme
URL:
Whiteboard: target:5.4.0
Keywords: difficultyBeginner, easyHack
: 106129 (view as bug list)
Depends on:
Blocks: 82707 Statusbar
  Show dependency treegraph
 
Reported: 2017-02-01 15:15 UTC by jfguichard
Modified: 2017-02-21 16:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jfguichard 2017-02-01 15:15:47 UTC
- Status bar of Writer
- Icon when the file is modified
- Tooltip (IN THE FRENCH VERSION !!!) saying that you must double-clic to save the file while a simple-clic is enough
Comment 1 V Stuart Foote 2017-02-01 16:21:47 UTC
Confirmed on Windows 10 Pro 64-bit en-US with
Version: 5.3.0.3 (x64)
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

On Windows builds only requires a single-click.

Looks to be a simple string adjustment [1] missed during work on bug 82707


=-ref-=
http://opengrok.libreoffice.org/xref/core/svx/source/stbctrls/stbctrls.src#103
Comment 2 V Stuart Foote 2017-02-01 18:47:51 UTC
set the easy hack, but impacts l10n
Comment 3 Adolfo Jayme 2017-02-02 02:11:52 UTC
Thanks for the finding! Fixed.
Comment 4 Commit Notification 2017-02-02 02:12:49 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5f33745c1d6750126e53a02b2a95355a3e5b16a0

tdf#105669 tdf#82707 A single click in the status bar is now enough

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Jacques Guilleron 2017-02-21 16:05:37 UTC
*** Bug 106129 has been marked as a duplicate of this bug. ***