Bug 105698 - Missing characters at the end of a word in bibliography
Summary: Missing characters at the end of a word in bibliography
Status: RESOLVED DUPLICATE of bug 104315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-02-02 12:07 UTC by michael.essich
Modified: 2017-02-03 03:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Missing characters in bibliography (14.71 KB, image/png)
2017-02-02 12:09 UTC, michael.essich
Details
test file (12.60 KB, application/vnd.oasis.opendocument.text)
2017-02-02 14:56 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description michael.essich 2017-02-02 12:07:06 UTC
Description:
When creating a bibliography for some fields (e.g. first name or short name) there is 1 character missing at the end of the word.

I can reproduce this behaviour with LibreOffice Version 5.3.0.3 (x64).

Steps to Reproduce:
1. Add a bibliography entry with Insert - Table of Contents and Index - Bibliography Entry (it doesn't matter if you choose an entry from Individual Document or Bibliography Database).
2. Create the bibliography with Insert - Table of Contents and Index - Table of Contents, Index or Bibliography and choose Bibliography.

Actual Results:  
There is 1 character missing at the end of the word for some fields (e.g. first name or short name).

Expected Results:
The bibliography should be complete and correct.


Reproducible: Always

User Profile Reset: Yes.

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 michael.essich 2017-02-02 12:09:16 UTC
Created attachment 130848 [details]
Missing characters in bibliography
Comment 2 Jacques Guilleron 2017-02-02 14:55:27 UTC
Hi michael,

I get the same behavior with:
LO 5.3.0.0.beta1 Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Layout Engine: new; Locale : fr-FR (fr_FR); Calc: CL
and upper versions
under windows 7 Home

I don't reproduce with:
LO 5.3.0.0.alpha1 Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Comment 3 Jacques Guilleron 2017-02-02 14:56:35 UTC
Created attachment 130852 [details]
test file
Comment 4 Aron Budea 2017-02-03 03:28:31 UTC
Thanks for the sample, I can confirm this is a duplicate of bug 104315.

*** This bug has been marked as a duplicate of bug 104315 ***