Bug 105703 - Custom motion path effect missing
Summary: Custom motion path effect missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.1 rc
Hardware: All All
: high normal
Assignee: Katarina Behrens (CIB)
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.4
Keywords: regression
: 107169 108369 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-02 14:55 UTC by Varga Péter
Modified: 2017-06-06 19:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Varga Péter 2017-02-02 14:55:52 UTC
Cannot find the effect in the motion path dialog in Impress

In fact I did not found it in the 5.3 _release_ (Windows version, downloaded today), but I cannot select it form the version list.

In this bug: 76916 the last entry says it is present in 5.2.x and I can confirm that too.
Comment 1 Varga Péter 2017-02-03 14:06:36 UTC
In 5.1.6 there is a Custom motion path effect, but the dialog was redesigned in 5.2.
Comment 2 Regina Henschel 2017-02-11 14:32:23 UTC
I can confirm that the subcategory "User Paths" from "Motion Paths" is missing. You need to start with a predefined path and alter it to your needs. The kind "Freeform line" is no longer available.

The same error was fixed in bug 76916 and now occurs again.
Comment 3 Regina Henschel 2017-04-15 12:44:35 UTC
*** Bug 107169 has been marked as a duplicate of this bug. ***
Comment 4 Katarina Behrens (CIB) 2017-05-02 07:55:19 UTC
Google Summer of Regressions
Comment 5 Commit Notification 2017-05-02 11:47:21 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=17495047e53885a224c2180c10ec7ecece35135d

tdf#105703: Restore user-defined motion paths for animations

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Katarina Behrens (CIB) 2017-05-02 11:52:10 UTC
I think this can be safely backported, no new or changed translatable strings (the strings were there all along, they were just not added to the list correctly)
Comment 7 Commit Notification 2017-05-03 13:56:18 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fd2fe3b370abb38200da04602a28d9696ad12e12&h=libreoffice-5-3

tdf#105703: Restore user-defined motion paths for animations

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-05-04 08:15:03 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9eae606ebc1ebd20dbc0aeb44e1f760e62afcdbe

tdf#105703: Make sure we actually have a motion path here

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Katarina Behrens (CIB) 2017-05-04 12:45:49 UTC
There are still some glitches, at least part of them covered by bug#94947, but the motion paths are now there and can be used => let's set this to fixed
Comment 10 Commit Notification 2017-05-09 07:53:17 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8501821f3b5ad541c40b5465aab000a6960b97ba&h=libreoffice-5-3

tdf#105703: Make sure we actually have a motion path here

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Regina Henschel 2017-06-06 19:00:26 UTC
*** Bug 108369 has been marked as a duplicate of this bug. ***