Download it now!
Bug 105714 - Link dialog icons and fields are too big
Summary: Link dialog icons and fields are too big
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2017-02-02 19:45 UTC by bordfeldt
Modified: 2019-03-05 19:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
link dialogue - too big icons, buttons and fields (153.48 KB, image/jpeg)
2017-02-02 19:46 UTC, bordfeldt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bordfeldt 2017-02-02 19:45:18 UTC
Description:
If I want to insert a link inta a writer document with the "insert link"-button in the standard toolbar, the link dialogue opens, but some icons and fields are too big. 

Steps to Reproduce:
1. open any writer document
2. insert a link
3. the link dialogue-window opens -> icons and fields are too big

Actual Results:  
in the link dialogue-window icons and fields are too big

Expected Results:
should be displayed normally


Reproducible: Always

User Profile Reset: No

Additional Info:
worked in 5.2.4.2


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 bordfeldt 2017-02-02 19:46:02 UTC
Created attachment 130865 [details]
link dialogue - too big icons, buttons and fields
Comment 2 Buovjaga 2017-02-07 13:04:20 UTC
What are your DPI scaling settings? Simply normal, or have you changed them? Do you have a HiDPI screen?
If your DPI scaling settings are normal, has the dialog always been like this or did it work in a previous version?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 3 bordfeldt 2017-02-07 13:11:30 UTC
>> What are your DPI scaling settings? 
2736x1824
>> Simply normal, or have you changed them? 
normal, didn't change
>> Do you have a HiDPI screen?
yes
>> If your DPI scaling settings are normal, has the dialog always been like this or did it work in a previous version?
worked on all previous versions on this machine, last working version 5.2.4.2
Comment 4 Buovjaga 2017-02-07 13:18:31 UTC
Ok, thanks. I guess it's still related to the HiDPI..
Comment 5 Buovjaga 2017-05-27 14:13:43 UTC
Confirmed on Manjaro Linux. Scaling factor 2

Version: 5.3.3.2
Build ID: 5.3.3-1
CPU Threads: 4; OS Version: Linux 4.11; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 6 Buovjaga 2017-05-27 14:26:25 UTC
Chirag: as you fixed bug 90795, I thought you might be interested in this one.
Comment 7 bordfeldt 2018-02-04 15:03:37 UTC
still present in 6.0.0.3
Comment 8 QA Administrators 2019-02-05 03:46:40 UTC Comment hidden (obsolete)
Comment 9 bordfeldt 2019-03-05 19:04:26 UTC
Now the link dialogue-window seems to be okay. But tested on 6.1.5.2 on Ubuntu 18.04 and not in Windows.
Comment 10 Buovjaga 2019-03-05 19:13:00 UTC
(In reply to bordfeldt from comment #9)
> Now the link dialogue-window seems to be okay. But tested on 6.1.5.2 on
> Ubuntu 18.04 and not in Windows.

As I confirmed it on Linux in 2017, let's close as WFM.