Download it now!
Bug 105717 - File Save a copy as CSV: remember Export CSV File dialog options
Summary: File Save a copy as CSV: remember Export CSV File dialog options
Status: RESOLVED DUPLICATE of bug 55236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks:
 
Reported: 2017-02-03 01:38 UTC by gekacheka
Modified: 2017-02-16 10:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gekacheka 2017-02-03 01:38:31 UTC
Tested LO Calc 5.3.0, MSWin7, en_US

File Save (a copy) as CSV: the Export Text File dialog options are forgotten after each export.  When exporting many tabs to separate files, or when repeating an edit/export/test cycle, setting these options over and over again is tedious and error prone.

Steps to reproduce:
0. Open a spreadsheet in LibreOffice Calc.

1a. File / Save a copy ...
(Save a copy dialog opens.)
2a. Select Save as type: Text CSV (.csv)
2b. click Save.
(Save a copy dialog closes and Export Text File dialog opens.)
 Character set:   windows-1252
 Field delimiter: ,
 Text delimiter:  "

3a. Select character set: UTF-8
3b. Select field delimiter: ;
3c. Click Ok
(Dialog closes and file is exported.)

(repeat)
4a. File / Save a copy ...
(Save a copy dialog opens.)
5a. Select Save as type: Text CSV (.csv)
5b. click Save.
(Save a copy dialog closes and Export Text File dialog opens.)

ACTUAL: settings are forgotten.  Must remember them and enter them each time before clicking ok.

 Character set:   windows-1252
 Field delimiter: ,
 Text delimiter:  "

EXPECT: settings are remembered.  Can click ok quickly.

 Character set:   UTF-8
 Field delimiter: ;
 Text delimiter   "
Comment 1 Buovjaga 2017-02-07 13:34:21 UTC
Reproduced. 4.4 seems to be the first with Save as copy.
"Save as" remembers the settings even in 3.5.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 83e059af2203ec0cd15dea08cfa538555ba14bd7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_23:34:43
Locale: fi-FI (fi_FI); Calc: group

Version: 4.4.5.2
Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99
Locale: fi_FI
Comment 2 Buovjaga 2017-02-16 10:29:55 UTC
I don't know, why I got the result that Save as remembers the settings. Now that I retested, I did not get them to remember. I will close this as a dupe of an older report about Save as.

*** This bug has been marked as a duplicate of bug 55236 ***