Bug 105720 - Left-aligned currency symbols in currency fields are displayed in the middle of the preceding cell (in some builds)
Summary: Left-aligned currency symbols in currency fields are displayed in the middle ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All Linux (All)
: medium minor
Assignee: Marco Cecchetti
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords: bibisected, regression
Depends on:
Blocks: Number-Format
  Show dependency treegraph
 
Reported: 2017-02-03 06:02 UTC by Aron Budea
Modified: 2019-01-13 13:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Repro spreadsheet (9.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-03 06:02 UTC, Aron Budea
Details
Screenshot (73.16 KB, image/png)
2017-02-03 06:03 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-02-03 06:02:23 UTC
Created attachment 130869 [details]
Repro spreadsheet

See attached spreadsheet and screenshot.

This bug doesn't occur with any TDF releases for me, but it occurs with self-built (dbgutil) 5.4 master build, and also with bibisect-linux-64-5.3 repo (even with oldest commit). All in Ubuntu 16.04, no repro at all in Windows.

While the repro builds are fairly recent, it doesn't mean the bug is a regression, it just depends on certain unknown factors.

Version: 5.4.0.0.alpha0+
Build ID: f3ba0c5d4dfc44f72aa7d4809c062227649f098f
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Aron Budea 2017-02-03 06:03:55 UTC
Created attachment 130870 [details]
Screenshot
Comment 2 Xisco Faulí 2017-02-05 16:18:22 UTC
I can't confirm it in

Version: 5.4.0.0.alpha0+
Build ID: fc53cce64400430cdc21f79c959d75fb9a26d13d
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Buovjaga 2017-02-08 15:31:18 UTC
Not seeing it with my own build.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 3598740b1cf8f679567e1536768084924e547616
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 8th 2016
Comment 4 Aron Budea 2017-04-03 02:35:43 UTC
Here's my current experience.

Reproducible (latest commits):
lo-linux-dbgutil-daily
lo-linux-dbgutil-daily-till53
lo-linux-dbgutil-daily-till52
lo-linux-dbgutil-daily-till51
bibisect-linux-64-5.3

Not reproducible:
TDF release builds
bibisect-50max
bibisect-linux-64-5.4 (not even with oldest commit)

At the moment it's not reproducible with a self-built master dbgutil build from a few days ago (0cb5435dd35674b6e55e22922a0819d2a755fc10), but that still doesn't mean anything, as it is reproducible with the latest daily dbgutil bibisect repo build from yesterday.
Comment 5 Aron Budea 2017-06-09 16:14:56 UTC
Using the daily bibisect repo I went back to lo-linux-dbgutil-daily-till44, and it started as of: 2014-06-11.

If I'm not mistaken, this is the range:
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=3466cbc01ccad09bf852fdbc470744940c5c3054..81d2c208a4e6f9df87e2ee70c6e6da146742178a

For me the bug is consistently reproducible using local builds with gtktiledviewer, so it occurs with tiled rendering even if it doesn't when LibreOffice is run normally:

bin/run gtktiledviewer $PWD/instdir/program <file>
Comment 6 Aron Budea 2017-11-30 15:40:15 UTC
Still there with a 6.1 master build (226c4c010e805fb899ab065c3837241861d6d6db) when using gtktiledviewer (tiled rendering). Marco Cecchetti could also reproduce it some time ago, let's set to NEW.
Comment 7 Xavier Van Wijmeersch 2017-12-01 15:38:51 UTC
I used the repro spreadsheet
I noticed in the format dialog this [$$-409]* #.##0,00;-[$$-409]* #.##0,00
There is * behind the [$$-409], when removing the * then the dollar occurs correct before the number.
Select all cells with the currency format, right click for the format dialog or ctrl+1  and you will see the problem

Version: 6.1.0.0.alpha0+
Build ID: 6ff84c8a890bf782e9e4f0557c117277289c2360
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 8 Aron Budea 2017-12-01 17:20:41 UTC
Thanks for checking Xavier.
Note that the issue isn't that the $ appears on the left side of the cell, that's what would be expected. The bug can be seen in the attached screenshot, attachment 130870 [details], the $ symbols are a lot more to the left than should be.

However, it only occurs with very few builds, or with tiled rendering (ie. online).
Comment 9 Commit Notification 2018-06-18 13:29:43 UTC
Marco Cecchetti committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=37210da00a9190f7765fa9c1e4a08629d2f4c2c4

tdf#105720: lok: sc: currency symbol is displayed in the preceding cell

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-06-20 19:44:18 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=93e9a3e2b545c853f53ffe28d2795f55ad29f304

tdf#66089 tdf#105720: only rely on bPixelToLogic

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Aron Budea 2018-06-21 00:48:55 UTC
It was interesting to see how this and bug 66089 had the same roots.
Thanks for figuring out the original fix, Marco!
Comment 12 Commit Notification 2018-06-21 02:23:26 UTC
Marco Cecchetti committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5f3c08cf061ae9c6c4cad74e6671c41394f00630&h=libreoffice-6-1

tdf#105720: lok: sc: currency symbol is displayed in the preceding cell

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-06-21 06:45:54 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b86a8857e6488bac1224a9eed471bcf930994399&h=libreoffice-6-1

tdf#66089 tdf#105720: only rely on bPixelToLogic

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 BogdanB 2019-01-13 13:09:31 UTC
Verified. Fixed in
Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded