Download it now!
Bug 105754 - Notebookbar does not update icon style until restart
Summary: Notebookbar does not update icon style until restart
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Theming
  Show dependency treegraph
 
Reported: 2017-02-04 16:22 UTC by Jeremy Bicha
Modified: 2018-12-10 22:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Bicha 2017-02-04 16:22:45 UTC
Seen on LibreOffice 5.0.0.3 x64 on Windows 10 and today's LibreOffice Dev I compiled on Ubuntu 17.04 Alpha amad64.

1. Select Tools>Options
2. In Advanced, Make sure "Enable experimental features" is checked.
3. Restart LibreOffice
4. Select View>Toolbar Layout>Notebookbar
5. Select Tools>Options
6. In View, change the "Icon Style"

What Happens
============
The Notebookbar keeps the old "Icon Style" until LibreOffice is restarted.

But the traditional Toolbar Layouts pick up the new icon style without needing a restart.
Comment 1 Buovjaga 2017-02-12 13:56:57 UTC
Strange.. it works for me.

Version: 5.3.0.3 (x64)
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.3
Build ID: 5.3.0-2
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: ac8197327d3ef4f3c94fb0746393863404df086b
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 11th 2016
Comment 2 Jean-Baptiste Faure 2017-02-12 17:11:40 UTC
What kind of Notebook Bar do you use? 
I reproduce the described behavior with Contextual Groups but not with Tabbed nor Contextual Single.

Version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~xenial1.1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: fr-FR (fr_FR.UTF-8); Calc: single

Set status to NEW.

Best regards. JBF
Comment 3 Buovjaga 2018-03-11 11:54:25 UTC
There is now also bug 116228 for the icon size. The reporter says resizing the window fixes it. Is the same true here?
Comment 4 andreas_k 2018-12-10 22:28:47 UTC
svtlo-ManagedMenuButton
-----------------------
When using svtlo-ManagedMenuButton the icon size is hardcoded and the icon name too, so it didn't come from the uno command. Using this widget is not recommended cause the icons get an update only after an restart and the size is fixed.
I use this command only if there is no other possibility (RecentFileList).

sfxlo-NotebookbarToolBox
------------------------
This is the prefered widget cause you can define the icon size (or use the size from the LibO settings dialog) and the icons get updated immediately.

tabbed and grouped notebookbar use sfxlo-NotebookbarToolBox (excl. RecentFileList), so this bug is visible ONLY in notebookbar_groups.ui (Heikobar). As Heikobar need a lot of work to bring it out of experimental, I recommend to close this bug cause I wrote how to fix this issue.