Bug Hunting Session
Bug 105791 - The line that links a highlighted word with its comment disappears after scrolling away from it and returns after hovering over the comment
Summary: The line that links a highlighted word with its comment disappears after scro...
Status: RESOLVED DUPLICATE of bug 101798
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-02-06 11:45 UTC by Miguel
Modified: 2017-05-09 17:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Image where we can see the comments and part of their lines that link with the words (201.34 KB, image/png)
2017-02-06 11:50 UTC, Miguel
Details
Document with several comments (6.12 MB, application/vnd.oasis.opendocument.text)
2017-02-07 09:16 UTC, Miguel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel 2017-02-06 11:45:36 UTC
Description:
When I insert several comments to a big Writer document (.odt), the line that goes from the selected word to the comment is not well displayed on screen. I have this problem after upgrading from 5.2 to 5.3 on Linux (Xubuntu), but it works well on Windows.

Version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~trusty1
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: es-ES (es_ES.UTF-8); Calc: group

Steps to Reproduce:
1. Open a Writer documents which has several pages.
2. Select words from any page and insert a comment (a line appears linking the word with its comment on the right side of the program).
3. Repeat the above step in different pages.
4. Move between pages and you will see that the lines are not well displayed on screen.
5. Put the mouse cursor over a comment and the line appears again, but this does not fix the problem.

Actual Results:  
The line that links a hightlighted word with its comment is not well displayed

Expected Results:
The line that links a hightlighted word with its comment should be well displayed. I didn't have this problem before with LO-5.2 (Linux)


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 Miguel 2017-02-06 11:50:22 UTC
Created attachment 130939 [details]
Image where we can see the comments and part of their lines that link with the words
Comment 2 Xisco Faulí 2017-02-06 11:59:28 UTC Comment hidden (obsolete)
Comment 3 Miguel 2017-02-07 09:16:04 UTC
Created attachment 130971 [details]
Document with several comments

There are several comments in this document. It is a small sample of my English grammatical errors. Please do not have fun with it ;-)
Comment 4 Miguel 2017-02-08 10:41:17 UTC
To enable OpenGL for all rendering fixes the problem.
Tools > Options... > View > Use OpenGL for all rendering

This has solved my problem, but I do not think that the bug is really fixed. This is only a way to skip the bug.

Thanks!
Comment 5 Buovjaga 2017-05-07 16:07:25 UTC
*** Bug 107664 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2017-05-09 17:30:11 UTC
This is only happening with GTK and git bisect points to cb382034b061b4acd4f0fd490f42af34517a7b8d which is the same commit as in bug 101798. Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 101798 ***