Bug Hunting Session
Bug 105807 - Sidebar buttons Page Styles, formatting and gallery all open the Navigator deck when switching from read-only to edit mode
Summary: Sidebar buttons Page Styles, formatting and gallery all open the Navigator de...
Status: RESOLVED DUPLICATE of bug 104229
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar Read-Only
  Show dependency treegraph
 
Reported: 2017-02-06 19:55 UTC by Telesto
Modified: 2017-12-21 11:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (11.57 KB, application/vnd.oasis.opendocument.text)
2017-02-06 19:55 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-02-06 19:55:23 UTC
Description:
When switching from read-only to edit mode sidebar buttons Page Styles, formatting and gallery open the Navigator deck (clicking the navigator deck button a second time will fix it)


Steps to Reproduce:
1. Download the attached file
2. Check if read-only is enabled
3. Click Edit mode
4. Click 'Page Styles' in the sidebar

Actual Results:  
Page styles/formatting/ gallery will open the Navigator deck

Expected Results:
Should be opening the corresponding deck


Reproducible: Always

User Profile Reset: YES; Only the first launch everything OK. 

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: a296a69c984b17cfbcd249cf6bdc191d08dff2a6
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_00:00:55
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 5.3.0.3 
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-02-06 19:55:45 UTC
Created attachment 130960 [details]
Example file
Comment 2 Buovjaga 2017-02-12 14:21:56 UTC
I can reproduce with the document (if I turn it to read-only first).

The way to repro from scratch:
1. New Writer document
2. Open Sidebar, change to Navigator
3. Save
4. Turn the file into read-only
5. Open it, Edit document and click Styles button in Sidebar

It returns back to normal after you click the Navigator button and then back to Styles.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: ac8197327d3ef4f3c94fb0746393863404df086b
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 11th 2016
Comment 3 Aron Budea 2017-12-21 11:43:15 UTC
I believe this is the same underlying issue as bug 104229.

*** This bug has been marked as a duplicate of bug 104229 ***