Bug Hunting Session
Bug 105831 - UI enhancement: Add a donate button in Help menu / About box / elsewhere
Summary: UI enhancement: Add a donate button in Help menu / About box / elsewhere
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Olivier Hallot
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Help-Menu
  Show dependency treegraph
 
Reported: 2017-02-07 14:18 UTC by Mike Saunders
Modified: 2017-12-30 00:44 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Saunders 2017-02-07 14:18:18 UTC
Description:
LibreOffice 5.3 introduced new links to online documentation in the Help menu. Olivier Hallot reports a 10x increase in web traffic to the online docs since then.

We could try something similar for donations. This could be a "Donate" or "Support LibreOffice" menu item, or a "Donate" button in the About dialog box or start center.

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:
-


Reproducible: Always

User Profile Reset: 

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 Cor Nouws 2017-02-07 17:56:06 UTC
For the Help menu: IMO this feels like "too much in need" (not to use another word with ..eed ;) ) 
In the About dialog: fine for me.
(I think to have seen it in other free software too in a similar place.)
Comment 2 V Stuart Foote 2017-02-07 18:15:55 UTC
Agree with Cor, please not a button on the Help menu. 

A button added to the About dialog would be less obnoxious.
Comment 3 Heiko Tietze 2017-02-16 12:14:46 UTC
Donate was suggested before in bug 96015 and no one disagreed on having an extra menu item. So please do it, Olivier.
Comment 4 Olivier Hallot 2017-03-13 20:37:07 UTC
Patch submitted

https://gerrit.libreoffice.org/#/c/34693/
Comment 5 Eike Rathke 2017-06-29 16:17:22 UTC
Fwiw, we need a quick and easy way to disable and suppress the entry altogether and not have it visible at all, for example using a configuration entry. This because in some environments a software may not be allowed to have a donation button/menu entry.
Comment 6 Olivier Hallot 2017-07-03 17:45:30 UTC
(In reply to Eike Rathke from comment #5)
> Fwiw, we need a quick and easy way to disable and suppress the entry
> altogether and not have it visible at all, for example using a configuration
> entry. This because in some environments a software may not be allowed to
> have a donation button/menu entry.

I have asked legal@tdf on the subject.

I'll appreciate to have a code pointer to wrap the menu entry in a configuration entry.
Comment 7 Olivier Hallot 2017-07-03 19:17:07 UTC
(In reply to Olivier Hallot from comment #6)
> 
> I have asked legal@tdf on the subject.
> 

I have the clearance filed in legal@tdf. The patch can be committed
Comment 8 Commit Notification 2017-07-04 13:48:58 UTC
Olivier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9cb1fe80b2dfd3684205277f5222df3d743d09d7

tdf#105831 Add Donate entry on Help menu

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Eike Rathke 2017-07-04 14:27:11 UTC
The legal aspect is one, but a company who paid for migration and support probably would not want that menu entry..
Comment 10 Thomas Lendo 2017-09-06 18:48:55 UTC
Seems to be implemented as "Donate to LibreOffice" in the Help menu. Is this bug fixed now?

Version: 6.0.0.0.alpha0+
Build-ID: 9c34471f54870fc685c343f4af30310e75d3a9ca
CPU-Threads: 4; Betriebssystem:Linux 4.10; UI-Render: Standard; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-06_02:17:21
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
Comment 11 Xisco Faulí 2017-12-07 08:43:46 UTC
A polite ping to Olivier Hallot: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 12 Cor Nouws 2017-12-28 19:41:52 UTC
I see a Donate entry in Help in Versie: 6.0.0.1
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU-threads: 4; Besturingssysteem: Linux 4.13; UI-render: standaard; VCL: gtk2; 
Locale: nl-NL (nl_NL.UTF-8); Calc: group

Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-12-26_23:09:36
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded