Bug 105843 - "Application Start" and "Application End" event options are not available
Summary: "Application Start" and "Application End" event options are not available
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Jean-Baptiste Faure
URL:
Whiteboard: target:5.4.0 target:5.3.2
Keywords: bibisected, bisected, regression
: 106688 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-07 21:23 UTC by Larry Horsley
Modified: 2017-03-30 06:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Horsley 2017-02-07 21:23:24 UTC
When trying to assign a macro to "Application Start" or "Application End", the event options are not available.
Comment 1 Buovjaga 2017-02-12 15:05:34 UTC
Confirmed that Start and Close application are gone in Customize - Events.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: ac8197327d3ef4f3c94fb0746393863404df086b
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 11th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 2 Xisco Faulí 2017-02-14 22:10:50 UTC
Regression introduced by:

author	Noel Grandin <noel@peralex.com>	2016-08-11 12:06:49 (GMT)
committer	Noel Grandin <noelgrandin@gmail.com>	2016-08-15 05:51:53 (GMT)
commit	d64395704e1a41e8f39e70a219ce3be90928e04d (patch)
tree	f04fd671709347e82752f2faa3aab30c9a0a9faf
parent	9532f45ff009f67940c77dccd463f3088866b75e (diff)
loplugin:unusedenumconstants in unotools..xmlhelp

Adding Cc: to Noel Grandin
Comment 3 Xisco Faulí 2017-03-22 09:29:56 UTC
*** Bug 106688 has been marked as a duplicate of this bug. ***
Comment 4 Jean-Baptiste Faure 2017-03-27 20:13:33 UTC
Submitted patch here : https://gerrit.libreoffice.org/#/c/35779/

Best regards. JBF
Comment 5 Commit Notification 2017-03-28 06:37:45 UTC
Jean-Baptiste Faure committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c0054f1b7c3c475bff7a5adfdea0feaecf20748

tdf#105843 : restore Application Start and Stop events

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Jean-Baptiste Faure 2017-03-28 08:51:10 UTC
Please, could it be possible to backport this commit to 5.3 branch ?

Best regards. JBF
Comment 7 Commit Notification 2017-03-28 21:31:55 UTC
Jean-Baptiste Faure committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98399c291239e309769fe9a1099655343b21ccd2&h=libreoffice-5-3

tdf#105843 : restore Application Start and Stop events

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Jean-Baptiste Faure 2017-03-29 04:20:57 UTC
Now fixed by commits 5 (master) and 7 (5.3.3).

Best regards. JBF
Comment 9 Commit Notification 2017-03-29 17:32:53 UTC
Jean-Baptiste Faure committed a patch related to this issue.
It has been pushed to "libreoffice-5-3-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=87f0803d1dfb0244ea2a473b55e87f6f2f1e8670&h=libreoffice-5-3-2

tdf#105843 : restore Application Start and Stop events

It will be available in 5.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.