Bug 105875 - FILEOPEN: DOCX: Shape rotation is wrong (see comment 3)
Summary: FILEOPEN: DOCX: Shape rotation is wrong (see comment 3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Balázs Regényi
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Anchor-and-Text-Wrap VML-Shapes
  Show dependency treegraph
 
Reported: 2017-02-09 10:45 UTC by Tobias Burnus
Modified: 2020-10-26 10:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX with a table and polygon shapes in form of arrows (34.03 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-02-09 10:45 UTC, Tobias Burnus
Details
Screenshot - top is MS Word 2007, bottom is LibreOffice (39.12 KB, image/png)
2017-02-09 10:53 UTC, Tobias Burnus
Details
We have retested this problem and it seems to be fixed in version 6.1.2. (213.66 KB, image/png)
2018-11-26 09:46 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2017-02-09 10:45:18 UTC
Created attachment 131034 [details]
DOCX with a table and polygon shapes in form of arrows

The attached file has been saved with Microsoft Office 2007 - and lacks in LO 5.3.0.3 and in a few days old LO MASTER the arrows created as poly shapes.
Comment 1 Tobias Burnus 2017-02-09 10:53:58 UTC
Created attachment 131035 [details]
Screenshot - top is MS Word 2007, bottom is LibreOffice

[For the lacking page splitting of the table, see bug 105876]
Comment 2 Xisco Faulí 2017-02-09 11:17:00 UTC
Regression introduced by:

author	Ravindra Vidhate <ravindra.vidhate@synerzip.com>	2014-04-16 10:02:43 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-04-17 08:10:37 (GMT)
commit	2496eaa5c4535b88b44e4ac034aae6af0c08de0e (patch)
tree	ad85d6763a1dabf1316de727c223db49dddfd11c
parent	7bda5f04a693c7943bc4201c11e73ca45bead661 (diff)
fdo#77219 Image property Z-index [behindDoc] not preserved after RT
Problem description:
For the images who has the "Text wrapping" property set as Behind Text
 is not preserved after saving the file in DOCX format using LO.

Adding Cc: to Ravindra Vidhate
Comment 3 Tobias Burnus 2018-02-05 08:42:22 UTC
Partial improvement:
[good] The arrows are now drawn (LO 6.0/LO master/6.1)
[bad] The top arrows are 180 degree rotated such that the arrow head shows up instead of down (i.e. LO/Bad: ⬏ ⬑ / MSO/Good: ⬎ ⬐)
Comment 4 NISZ LibreOffice Team 2018-11-26 09:46:53 UTC
Created attachment 147033 [details]
We have retested this problem and it seems to be fixed in version 6.1.2.
Comment 5 Buovjaga 2018-11-26 13:34:34 UTC
Let's keep this for the shape rotation issue.
Comment 6 Xisco Faulí 2019-10-17 12:48:53 UTC
Still reproducible in

Version: 6.4.0.0.alpha1+
Build ID: 01d28b0b85f99590c0581e4bbf636bc9281e0571
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Commit Notification 2020-10-06 09:23:11 UTC
Regényi Balázs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3b6de95a0d59cf5942af5ecf4a402c224b76f8a3

tdf#105875 DOCX VML shape import: fix missing rotation

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-10-06 14:07:46 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: ff5ca4e5fc6a9fb24b0eb6eb629210b024473f67
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Balázs Regényi, thanks for fixing this issue!!
Comment 9 Commit Notification 2020-10-07 08:15:39 UTC
Regényi Balázs committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/767ec919f09e5ed69149ed27bd46a6bb67556863

tdf#105875 DOCX VML shape import: fix missing rotation

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.