Bug 105916 - LibreOffice 5.3.0.3 Writer distorts bibliographic references
Summary: LibreOffice 5.3.0.3 Writer distorts bibliographic references
Status: RESOLVED DUPLICATE of bug 104315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-02-10 12:15 UTC by Karel Hruska
Modified: 2017-02-10 15:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Reference list rendered in LO 5.2.5.1 (124.45 KB, image/png)
2017-02-10 12:16 UTC, Karel Hruska
Details
Reference list rendered in LO 5.3.0.3 (125.40 KB, image/png)
2017-02-10 12:17 UTC, Karel Hruska
Details
Sample document (688.47 KB, application/vnd.oasis.opendocument.text)
2017-02-10 12:38 UTC, Karel Hruska
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karel Hruska 2017-02-10 12:15:36 UTC
Description:
The bibliographic references list generated in LibreOffice Writer gets distorted after refresh.

Steps to Reproduce:
1. Open an old document with bibliographic references.
2. Refresh bibliographic references.
3. The list of references looses numbering and last letters of some entries disappear.

Actual Results:  
Distorted reference list.

Expected Results:
Correct reference list.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.76 Safari/537.36
Comment 1 Karel Hruska 2017-02-10 12:16:34 UTC
Created attachment 131069 [details]
Reference list rendered in LO 5.2.5.1
Comment 2 Karel Hruska 2017-02-10 12:17:07 UTC
Created attachment 131070 [details]
Reference list rendered in LO 5.3.0.3
Comment 3 Xisco Faulí 2017-02-10 12:22:37 UTC Comment hidden (obsolete)
Comment 4 Karel Hruska 2017-02-10 12:38:54 UTC
Created attachment 131072 [details]
Sample document

Thank you extremely fast response, Xisco,
the problematic document is attached. I am not sure about the origin of the document (might be an MS Office conversion), but the reference list was added in LO 5.2.5 and the same behaviour have also older documents originally mad in LibreOffice.

Karel
Comment 5 Xisco Faulí 2017-02-10 15:10:25 UTC
Regression introduced by 250252d02bac88877845a4bc27e3f1837f1312ba which is the same commit as in bug 104315
Closing as RESOLVED DUPLICATE

*** This bug has been marked as a duplicate of bug 104315 ***