Bug 105947 - Pattern area fill does not work for chart wall
Summary: Pattern area fill does not work for chart wall
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart Object-Fill-Pattern
  Show dependency treegraph
 
Reported: 2017-02-11 21:19 UTC by Tamás Zolnai
Modified: 2018-04-16 13:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document with a chart (13.29 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-11 21:20 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-02-11 21:19:38 UTC
Description:
When I try to set a pattern fill background to a chart wall, the chart wall's background does not show the right result.

Steps to Reproduce:
1. Open attached file with a chart
2. Double click on chart -> step into edit mode
3. Double click on chart wall (area showing the chart data and chart grid)
4. Open Area tabpage, push Pattern button and select a new pattern with a new color
5. Close Chart Wall dialog
6. Result: Char Wall background does not change, it remains the same gray beckground.

Actual Results:  
Chart Wall background does not have the right background fill.

Expected Results:
Chart Wall background should show a pattern fill.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 Tamás Zolnai 2017-02-11 21:20:02 UTC
Created attachment 131109 [details]
Test document with a chart
Comment 2 Tamás Zolnai 2017-02-11 22:04:57 UTC
Also note that when I set some pattern fill for chart wall and reopen the dialog and the Area tab page not the Pattern settings are opened, but the Bitmap settings.
Comment 3 Tamás Zolnai 2017-02-11 22:11:15 UTC
Setting background fill to Chart Area has similar problem.
Comment 4 Xisco Faulí 2017-02-12 11:16:51 UTC
I supposed this the the exact problem as in bug 105922 which I reported just 2 days ago...
Comment 5 Katarina Behrens (CIB) 2017-02-17 22:32:55 UTC
Yep
Comment 6 Jorge Juan 2017-11-08 09:34:49 UTC
(In reply to Katarina Behrens (CIB) from comment #5)
> Yep

No, it is not. bug 105922 is supposed to be solved in 5.4.0 but this bug is still present in 5.4.2.

It is likely the same problem as in bug 113688 that is reported to also affect 6.0.0.0.alpha1+
Comment 7 Katarina Behrens (CIB) 2018-04-16 10:44:54 UTC
This is WFM now on 6.1 (master build) but I've no idea which commit fixed it

My money would have been on this one: https://cgit.freedesktop.org/libreoffice/core/commit/?id=2eaa978d135a53abf22df2dc3fcb8d04733fe2d3 but nope, it has happened way before.

So ... what to do now, QA people? Can any1 confirm what I've seen? And if so, is there anything like bibisect that identifies commit that fixed it (not the commit that broke it)? So we can eventually backport to stable versions
Comment 8 Xisco Faulí 2018-04-16 13:14:20 UTC
I do confirm the issue is fixed in

Version: 6.1.0.0.alpha0+
Build ID: b36ea44dcbdb862b0ac6e6cdaf27225b43dc0c7e
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Fixed by: https://cgit.freedesktop.org/libreoffice/core/commit/?id=ec05c7fd4a0e09e0c953f243475cbc7db9afb02c
Comment 9 Xisco Faulí 2018-04-16 13:15:46 UTC
> So ... what to do now, QA people? Can any1 confirm what I've seen? And if
> so, is there anything like bibisect that identifies commit that fixed it
> (not the commit that broke it)? So we can eventually backport to stable
> versions

Yes, we add 'backportRequest' to the whiteboard in that case...