Bug 105949 - "Document" preview in Base displays menu as garbled junk
Summary: "Document" preview in Base displays menu as garbled junk
Status: RESOLVED DUPLICATE of bug 66237
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-11 23:48 UTC by Daniel C Scearce
Modified: 2017-02-20 11:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Visual dipiction of bug, see box in lower right corner (129.23 KB, image/jpeg)
2017-02-11 23:49 UTC, Daniel C Scearce
Details
Bigger view of garbled "document" presentation (10.11 KB, image/png)
2017-02-20 11:15 UTC, sergeyshanygin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel C Scearce 2017-02-11 23:48:03 UTC
Description:
"Document" preview (on lower right) in Base displays Table menu as garbled junk until the window is resized.

I don't recall the first version that this affects but I can confirm that it has been a longstanding eyesore with Base, so I've decided to finally report the bug. (I will attach a photo [which will do much better than words]) This clearly qualifies as a bug, and I did a search to check for duplicates. Unfortunately, I cannot fix it myself as I am a PHP/JS/Node programmer only.

Why I think this merits valuable coding time:

LibreOffice is mature software, this flaw is obvious and doesn't do justice to the software suite. It will go a long way toward making LibreOffice a more formidable and quality software.

Steps to Reproduce:
1. Open Base
2. Create a Table with a nonzero amount of items
3. Have said table selected in main window
4. Select "Document" in lower right dropdown box.

Actual Results:  
"Document" preview (on lower right) in Base displays Table menu as garbled junk until the window is resized.

Expected Results:
Menu should be displayed correctly


Reproducible: Always

User Profile Reset: No, this always happens with fresh installs.

Additional Info:
Fresh install, Latest Java runtime is installed on a fresh install of Windows 7.


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Daniel C Scearce 2017-02-11 23:49:09 UTC
Created attachment 131111 [details]
Visual dipiction of bug, see box in lower right corner
Comment 2 Robert Großkopf 2017-02-12 08:48:15 UTC
Duplicate of a just fixed bug. Fix available in LO 5.3.1

*** This bug has been marked as a duplicate of bug 66237 ***
Comment 3 sergeyshanygin 2017-02-20 11:15:39 UTC
Created attachment 131350 [details]
Bigger view of garbled "document" presentation
Comment 4 sergeyshanygin 2017-02-20 11:25:16 UTC
I fully confirm observations by Daniel, I always experience exactly the same results. 

With only difference that I run Ubuntu previously and Linux Mint 18.1 with LO  5.3.0.3 lately.

My Base install is a front end to MySql, if that matters.

Would be great to see this unpleasant bug gone forever...