Bug 105971 - FILEOPEN DOC Image with absolute position to margin is positioned incorrectly if "Layout in table cell" is set
Summary: FILEOPEN DOC Image with absolute position to margin is positioned incorrectly...
Status: RESOLVED DUPLICATE of bug 115896
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Opening
  Show dependency treegraph
 
Reported: 2017-02-13 02:14 UTC by David Chambers
Modified: 2020-04-24 07:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of format issue opening a word.doc (166.72 KB, application/x-zip-compressed)
2017-02-14 00:39 UTC, David Chambers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Chambers 2017-02-13 02:14:31 UTC
Description:
The .doc file (document)is fine when opened in Microsoft Word (various versions)However when opened in Libre 5.3 the contents of a table contain signature images does not present correctly.

Steps to Reproduce:
1.Open file
2.
3.

Actual Results:  
A signature appears elsewhere in the document not in the table.

Expected Results:
Same as for MS Word


Reproducible: Always

User Profile Reset: No

Additional Info:
Hopefully I can find Add Attachment after filing.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393
Comment 1 David Chambers 2017-02-13 02:20:28 UTC Comment hidden (obsolete)
Comment 2 Julien Nabet 2017-02-13 10:53:37 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2017-02-13 14:35:34 UTC Comment hidden (obsolete)
Comment 4 David Chambers 2017-02-14 00:39:24 UTC
Created attachment 131197 [details]
Example of format issue opening a word.doc
Comment 5 David Chambers 2017-02-14 00:45:31 UTC
Expanding on the format problem. The signature on the left appears amongst other text higher up the document in Libre office Writer also the Text written names move. Needs to be opened in Libre Writer and MS Word to see the difference.
Comment 6 Buovjaga 2017-02-17 14:44:14 UTC
Confirmed.

The well-behaving other signature is anchored As character. So, change the unruly one to As character to get an immediate fix to the problem.

I could not find a duplicate, which was somewhat surprising..

Win 8.1 32-bit
LibO Version: 5.4.0.0.alpha0+
Build ID: 9077f1f110a35ed223fb47e9eaa329dd19528e38
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-16_23:34:39
Locale: fi-FI (fi_FI); Calc: group
Comment 7 David Chambers 2017-02-18 00:12:06 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2017-02-18 10:32:27 UTC
(In reply to David Chambers from comment #7)
> Thanks for your testing and input. I question why MS Word can cope and not
> Writer. There may well be an error to document creation or image
> positioning, however Word does seem to cope. The document is one of a series
> of newsletters produced by a lady. All readers with MS word see no problems,
> but Libre Writer readers see this signature image problem. I do not
> understand your AS character statement, I need to understand so that I can
> recommend to the document creator a practice of image placing that is stable
> and compatible with Writer. 

I can't tell you off the top of my head, how to anchor it As Character in Word. You may try to fix it in LibreOffice by re-positioning the image in the table and right-clicking it and selecting Anchor - As Character from the context menu.

For sure it is a bug in LibreOffice.
Comment 9 Buovjaga 2017-02-18 15:04:19 UTC
Already seen in 3.3.

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 10 David Chambers 2017-02-21 01:13:43 UTC Comment hidden (no-value)
Comment 11 Timur 2018-02-20 13:30:23 UTC
Seems the left image has absolute position to margin and "Layout in table cell" in Word. If "Layout in table cell" is turned off, Word shows position as Writer. 
I guess Writer doesn't understand that combination and so sets wrong margin.
Right image also has "Layout in table cell" but it's absolute position is to column and paragraph.
Comment 12 QA Administrators 2019-04-20 02:58:32 UTC Comment hidden (obsolete, spam)
Comment 13 Justin L 2020-04-17 15:05:37 UTC
repro 7.0+
Comment 14 Justin L 2020-04-24 07:16:51 UTC

*** This bug has been marked as a duplicate of bug 115896 ***