Bug Hunting Session
Bug 105982 - Print Preview: Cells are intertwined (steps: Comment 12)
Summary: Print Preview: Cells are intertwined (steps: Comment 12)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-13 14:40 UTC by Gülşah Köse
Modified: 2018-02-27 14:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The file, has main problem (19.04 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-13 14:43 UTC, Gülşah Köse
Details
How I see it (2.20 KB, image/png)
2017-02-13 15:42 UTC, Xisco Faulí
Details
Problematic seem (2.68 KB, image/png)
2017-02-13 15:49 UTC, Gülşah Köse
Details
Thats is last problematic file. (16.94 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-14 07:42 UTC, Gülşah Köse
Details
Some detections about bug (159.69 KB, image/png)
2017-02-21 09:31 UTC, Gülşah Köse
Details
New detection about line spacing (64.64 KB, image/png)
2017-02-23 07:25 UTC, Gülşah Köse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2017-02-13 14:40:38 UTC
Description:
The file at the attach is converted from .xlsx and simplified. Cells are intertwined while print preview mode and when printed.  

Steps to Reproduce:
1.Open the file at the attachment.
2.Click print preview


Actual Results:  
A1 and A2 cells intertwined

Expected Results:
It should show true margin values. (Default 0,35mm from all sides) 


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Gülşah Köse 2017-02-13 14:43:17 UTC
Created attachment 131180 [details]
The file, has main problem
Comment 2 Xisco Faulí 2017-02-13 15:42:36 UTC
Created attachment 131186 [details]
How I see it

I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: a25b1ff25a3be97d688d66b12353b4217fd239a5
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Gülşah Köse 2017-02-13 15:49:31 UTC
Created attachment 131187 [details]
Problematic seem

Strange. I've added problematic seem. Can anyone test it again
Comment 4 Xisco Faulí 2017-02-13 16:02:02 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: a296a69c984b17cfbcd249cf6bdc191d08dff2a6
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_00:00:55
Locale: es-ES (es_ES); Calc: group

To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?
Comment 5 Gülşah Köse 2017-02-14 07:42:19 UTC
Created attachment 131201 [details]
Thats is last problematic file.

The first problematic file was wrong file, sorry. All cells must be optimal height. I've add last problematic file.

By the way user profile reseted. Problem is going on. Lang: tr-TR
Comment 6 Gülşah Köse 2017-02-14 11:31:30 UTC
Microsoft Office 2010 has same issue.
Comment 7 Xisco Faulí 2017-02-14 23:53:19 UTC
(In reply to Gülşah Köse from comment #6)
> Microsoft Office 2010 has same issue.

should we consider this as a bug then ?
Comment 8 Gülşah Köse 2017-02-15 08:08:48 UTC
Yes, i think. Cell seen and print seen different in any case.
Comment 9 Xisco Faulí 2017-02-15 09:14:48 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 880033edde516fc30225005245253293a6a58ba4
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 10 Aron Budea 2017-02-17 00:52:54 UTC
Hm, I'm gettin this in 3.3.0 / Windows 7 as well.
Comment 11 Gülşah Köse 2017-02-19 10:17:22 UTC Comment hidden (obsolete)
Comment 12 Gülşah Köse 2017-02-19 10:18:34 UTC
(In reply to Gülşah Köse from comment #11)
> I found new reproducement steps without excel
> 
> 1. Open calc
> 2. Expand A column till B column with mouse
> 3. Type one line XXXXXXXXXXXXXXXXX to A1
> 4. Type one line YYYYYYYYYYYYYYYYY TO A2
> 5. Select all cells with Ctrl+A and click "Wrap text"
> 6. Now copy the YYYYYYYYYY line and paste 20 times. (to same cell)
> 7. See print preview
> 
> Actual Results:  
> A1 and A2 cells intertwined
> 
> Expected Results:
> It should show true margin values. (Default 0,35mm from all sides)

So sorry second step should be: 2. Expand A column till C column with mouse
Comment 13 Gülşah Köse 2017-02-21 09:31:05 UTC
Created attachment 131380 [details]
Some detections about bug

*Cells colorized for easy to see if cells or text intertwined. (Text)
*Row count is different on tab view an preview view.
*Right margin of cell is different on tab view an preview view.
Comment 14 Aron Budea 2017-02-23 03:46:45 UTC
Also seeing it in 3.3.0 / Ubuntu 16.04. Not a regression I think.
Comment 15 Gülşah Köse 2017-02-23 07:25:25 UTC
Created attachment 131421 [details]
New detection about line spacing

There is no option in calc increase/decrease line spacing of the paragraph but Tab view and print preview view has different line spacing as you see attach. Print preview view has looser line spacing Although it has fewer rows. I think the cell overflow can be caused by this.
Comment 16 QA Administrators 2018-02-24 03:34:19 UTC Comment hidden (obsolete)
Comment 17 Timur 2018-02-26 14:10:20 UTC
Since I repro with 5.4.1 beta and not with 5.4.3 and 6.0.1 in Windows, I'll close as WFM. 
Gülşah, just revert if you still see it.
Comment 18 Gülşah Köse 2018-02-27 14:06:49 UTC
It seems resolved. Thanks for testing.