Bug 106002 - Spin animation lost if export to pptx
Summary: Spin animation lost if export to pptx
Status: RESOLVED DUPLICATE of bug 112280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PPTX-Corrupted
  Show dependency treegraph
 
Reported: 2017-02-14 16:35 UTC by Regina Henschel
Modified: 2017-09-07 18:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
one slide with block arrow which rotates (9.81 KB, application/vnd.sun.xml.impress)
2017-02-14 16:35 UTC, Regina Henschel
Details
Powerpoint Export (38.65 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-03-21 01:53 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2017-02-14 16:35:36 UTC
Created attachment 131210 [details]
one slide with block arrow which rotates

Open attached document and play the presentation. On click the arrow should rotated 720°. That is done by the "Spin" effect.
Export the presentation to either of the two pptx formats. Unzip the file and open the file "slide1.xml". Open the <p:timing> element completely. Notice, that in the <p:cTn> element with id="5" the element <p:childTnLst> is empty. It should contain a <p:animRot> element. Opening the exported file in PowerPoint results in an error.

I see the error already in LO 4.1 and it still exists in LO 5.4.
Comment 1 Xisco Faulí 2017-02-14 22:55:36 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 880033edde516fc30225005245253293a6a58ba4
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Validating it in Open XML SDK 2.5 I get the following error:

Error Node type: ChildTimeNodeList
Error Description: The element has incomplete content
Comment 2 Luke 2017-03-21 01:53:53 UTC
Created attachment 132037 [details]
Powerpoint Export

From the PowerPoint 2013 export, it the OOXML command for a double spin is

<p:animRot by="43200000">
Comment 3 Xisco Faulí 2017-08-31 22:54:37 UTC
Still reproducible in

Version: 6.0.0.0.alpha0+
Build ID: 04d70c0999c716f5465631eca50945915ec607c4
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Jan Holesovsky 2017-09-07 18:07:22 UTC
Actually I think I've got a fix for this, but in bug 112280:

https://gerrit.libreoffice.org/#/c/42074/
https://gerrit.libreoffice.org/#/c/42075/

Let me mark as duplicate; feel free to re-open if it's not the case.

*** This bug has been marked as a duplicate of bug 112280 ***