Bug 106005 - source directory misdiscribtion of in the order & number after update from 5.2.4
Summary: source directory misdiscribtion of in the order & number after update from 5.2.4
Status: RESOLVED DUPLICATE of bug 104315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-02-14 18:26 UTC by Stefan Golla
Modified: 2017-02-15 12:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is a small testfile of the big one, with deleted pages (1.20 MB, application/vnd.oasis.opendocument.text)
2017-02-14 22:05 UTC, Stefan Golla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Golla 2017-02-14 18:26:29 UTC
Description:
After updating from 5.2.4 to 5.3.0.3 the source directory appeared wrong in the content of the source numbers, while updating. Originaly i got over 500 sources, but now it shows like 45 in breakets but the content behind the breakets is correct and also the number an order in the wohle document. The page number in the content is correct. This bug appears with the page bug in the ToC "@", the table of grafics was not effected by the update.

Actual Results:  
[] bla1
[] bla2
[] bla3
[] bla4
[1] bla5
[1] bla6
[1] bla7
[2] bla8
[2] bla9
.
.


Expected Results:
[1] bla1
[2] bla2
[3] bla3
[4] bla4
[5] bla5
.
.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Stefan Golla 2017-02-14 22:05:33 UTC
Created attachment 131227 [details]
This is a small testfile of the big one, with deleted pages

The original File is some 60 MB big, with more the 100 Pics and 200 Pages, this Testversion is just a smal peace that will work properly for debugging. I recently tested the bug at my windows XP PC with Libreoffice 5.2.4 and the both bugs, with the Table of content AND the other bug I reported with the source table, disappeard. and now on my Antergos-Linux Laptop with LibreOffice 5.3.0.3 just enables the bug, after updating the tables manually.
Comment 2 Stefan Golla 2017-02-15 00:51:40 UTC
After trying to resolve my first bug 106004, it appeared, that this is still a running bug reason like bug 104315!. So the problem is, that if any letter is put ahead or after the "Ku" so the real Index will be killed anyway.
So please fix that last Patch with the sign/letter to the Version 5.2.4, where it still work propper, or fix the new patch with no disablements
Thanks alot!
Comment 3 Xisco Faulí 2017-02-15 12:54:17 UTC
Regression introduced by 250252d02bac88877845a4bc27e3f1837f1312ba, which is the
same commit as in bug 104315. Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 104315 ***