Download it now!
Bug 106007 - Can't begin selection in header or footer with mouse when cursor is out of text limit
Summary: Can't begin selection in header or footer with mouse when cursor is out of te...
Status: RESOLVED DUPLICATE of bug 47101
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer Selection
  Show dependency treegraph
 
Reported: 2017-02-14 18:50 UTC by Fabien08FR
Modified: 2018-10-26 19:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file to test selection problem (10.87 KB, application/vnd.oasis.opendocument.text)
2017-02-14 18:50 UTC, Fabien08FR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabien08FR 2017-02-14 18:50:14 UTC
Created attachment 131219 [details]
ODT file to test selection problem

When in header or footer, text begins or ends outside text boundaries area, it is impossible to select text with mouse if i begin the selection with text outside. 

For exemple with the example attached : in header, if i begin selecting text inside "Loren" with mouse, selection don't work. In page main text area, no problem. 

If i moove cursor with keyboard and use shift+arrow to select, no problem.

Tip : use Display/text boundaries to help selection. No matter if text boundaries are shown or not.

Bug also found in 5.3.0.0 alpha+
Comment 1 Buovjaga 2017-02-19 19:13:19 UTC
Repro with document.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 7ec0500e20cf273d70c4fbddb4063b8f8295307c
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 18th 2016

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 QA Administrators 2018-02-20 03:37:32 UTC Comment hidden (obsolete)
Comment 3 Dieter 2018-02-20 08:30:26 UTC
Still reproducible with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 77a535285f0fd5f2464430abdc67cf99be024868
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-01-23_23:04:23
Locale: de-DE (de_DE); Calc: CL
Comment 4 Thomas Lendo 2018-10-26 19:28:18 UTC

*** This bug has been marked as a duplicate of bug 47101 ***