Download it now!
Bug 106092 - Bibliography list: last character gets eaten away if field separator is set
Summary: Bibliography list: last character gets eaten away if field separator is set
Status: RESOLVED DUPLICATE of bug 104315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2017-02-19 22:03 UTC by Mihkel Tõnnov
Modified: 2017-02-19 22:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Bibliography test (generated with LibO 5.2) (10.07 KB, application/vnd.oasis.opendocument.text)
2017-02-19 22:11 UTC, Mihkel Tõnnov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2017-02-19 22:03:13 UTC
If I create a bibliography entry with the following data:
Short name: Test
Author: Author
Title: Title
Year: 2017

...and add a bibliography list with following structure:
[Sh][ = ][Au][, ]Ti[, ][Ye][.]

...then the respective entry is shown like this in the actual bibliography list:
Tes = Autho, Titl, 201.

For comparison, if structure is just "[Sh][][Au][][Ti][][Ye]" without any spaces or commas between the fields, it gets shown as "TestAuthorTitle2017" -- that is, nothing is clipped. So the bug is somehow triggered by the "separator" characters/spaces between the bibliography structure fields.

This is a regression in LibO 5.3 -- it works as expected in 5.2.
Broken at least by 5.3.0.0 beta 1, maybe earlier; still broken in 5.3.0.3.
Comment 1 Mihkel Tõnnov 2017-02-19 22:11:33 UTC
Created attachment 131344 [details]
Bibliography test (generated with LibO 5.2)

Steps to reproduce the bug:
1) Open attached test document in LibO 5.3
2) Refresh bibliography list
3) Observe how the last characters disappear :)
Comment 2 Aron Budea 2017-02-19 22:33:29 UTC
This bug will be fixed in 5.3.1.

*** This bug has been marked as a duplicate of bug 104315 ***