Download it now!
Bug 106100 - presentation with svgs mangled in >= 5.2
Summary: presentation with svgs mangled in >= 5.2
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.2.6.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:svg, regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2017-02-20 11:50 UTC by Caolán McNamara
Modified: 2018-12-17 09:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
demo presentation (293.93 KB, application/vnd.oasis.opendocument.presentation)
2017-02-20 11:51 UTC, Caolán McNamara
Details
how it should look (24.61 KB, image/png)
2017-02-20 13:35 UTC, Xisco Faulí
Details
Screenshot ODP in 6.3 vs Should (from Caolan) (134.09 KB, image/png)
2018-12-16 20:50 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Caolán McNamara 2017-02-20 11:50:43 UTC
Description:
document attached look good before...

commit a2d8a9873deb5b39198c346cf637a9a8cb9e5105
Author: Regina Henschel <rb.henschel@t-online.de>
Date:   Wed Feb 10 15:26:37 2016 +0400

    tdf#97538 no cropping if width, height and viewBox missing

but is now mangled

Actual Results:  
three bands of colors and a large person icon

Expected Results:
three arrows and a small person icon


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Caolán McNamara 2017-02-20 11:51:12 UTC
Created attachment 131352 [details]
demo presentation
Comment 2 Xisco Faulí 2017-02-20 13:34:42 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 880033edde516fc30225005245253293a6a58ba4
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Xisco Faulí 2017-02-20 13:35:08 UTC
Created attachment 131359 [details]
how it should look
Comment 4 Xisco Faulí 2017-02-20 13:35:50 UTC
Adding Cc: to Regina Henschel
Comment 5 Regina Henschel 2017-02-20 18:03:26 UTC
The SVG image do not have width and height set. So what size is correct for such an image?

The current solution is, that the whole content is shown and the bounding box is expanded to the ratio given by the viewBox.

That was different before the patch. The old solution produced the errors described in bug 97538.

If you generate a new document with a current LO version, you will have no problems with the SVG images.

The attached document shows the images different, because the crop values do not fit to the now used size of the image. You can adapt the document by setting new values in the crop image dialog. It seems to me, that you can set the crop margins to 0cm after you have set the scaling to reasonable values.

I do not know, whether it is possible at all to fix bug 97538 and the problem here in a combined solution.
Comment 6 QA Administrators 2018-02-21 03:36:55 UTC Comment hidden (obsolete)
Comment 7 Roman Kuznetsov 2018-12-16 20:49:32 UTC
in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-12_03:38:09
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

presentation from attach looks fine

Status->WFM
Comment 8 Roman Kuznetsov 2018-12-16 20:50:29 UTC
Created attachment 147616 [details]
Screenshot ODP in 6.3 vs Should (from Caolan)
Comment 9 Xisco Faulí 2018-12-17 09:24:12 UTC
Seems to be fine in

Versió: 6.1.3.2
ID de la construcció: 1:6.1.3~rc2-0ubuntu0.16.04.1
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded

as well!!