Bug 106125 - FILESAVE Calc don't save size font style default, change if open file in other app.
Summary: FILESAVE Calc don't save size font style default, change if open file in othe...
Status: RESOLVED DUPLICATE of bug 112559
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ods
Depends on:
Blocks: ODF-export-invalid
  Show dependency treegraph
 
Reported: 2017-02-21 11:00 UTC by gmolleda
Modified: 2021-08-03 09:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gmolleda 2017-02-21 11:00:26 UTC
Open a new spreadsheet in Calc, 
write a text in first cell A1, the size font is 10
save file.

Open file with Calligra Sheets -> the size font is 9
Open file with Excel -> the size font is 11

If you change manually the font size, then the font size is saved in the file.

Español:
Abrir una nueva hoja de cálculo en Calc,
escribir un texto en la primera celda A1, el tamaño de letra es 10
Guardar el archivo.

Abrir el fichero en Calligra Sheets -> el tamaño de letra es 9.
Abrir el fichero en Excel -> el tamaño de letra es 11.

Si cambias el tamaño de letra manualmente, entonces ese tamaño es guardado en el fichero.

Esperanto:
Malfermu novan tabelon en tabelprogramo Calc,
skribu tekston en la unua ĉelo A1, la grando de la signaro estas 10
gardu dosieron.

Malfermu la dosieron per Calligra Sheets -> la grando de la signaro estas 9
Malfermu la dosieron per Excel -> la grando de la signaro estas 11

Se vi ŝanĝas la grando de la signaro mane, tiam tiu grando gardiĝos en la dosieron.
Comment 1 Buovjaga 2017-03-04 17:36:13 UTC
Reproduced with .ods and Excel 2013

Not sure, if considered bug, but setting to NEW so we can get a precedent.

Version: 5.4.0.0.alpha0+
Build ID: 9077f1f110a35ed223fb47e9eaa329dd19528e38
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-16_23:34:39
Locale: fi-FI (fi_FI); Calc: group
Comment 2 QA Administrators 2018-03-05 03:38:47 UTC Comment hidden (obsolete)
Comment 3 Thomas Lendo 2018-03-05 21:40:04 UTC
I didn't find a font size attribute of the Default cell style in the xml files. Regina, is something missing when exporting an ods file from LibreOffice or do I miss something and the other apps are doing something wrong?
Comment 4 gmolleda 2018-03-06 09:35:46 UTC Comment hidden (no-value)
Comment 5 gmolleda 2018-03-06 10:07:56 UTC
If I create a new document with Excel, and save it with .ods format. The size fonts are saved well, because if I open the file with LibreOffice Calc or Calligra Sheets the size of letters is the same that in Excel: 11.

Se mi kreas novan dokumenton kun Excel, kaj mi konservas ĝin en formato .ods. La tiparo estas bone savita, ĉar se mi malfermas la dosieron kun LibreOffice Calc aŭ Calligra Sheets, la grando de la literoj ankoraŭ estas 11 (kio ĝi estas en Excel).

Si yo creo un nuevo documento con Excel, y lo guardo con formato .ods. El tamaño de letra es guardado bien, porque si yo abro el fichero con LibreOffice Calc o Calligra Sheets el tamaño de las letras sigue siendo 11 (que es el de Excel).
Comment 6 Regina Henschel 2018-11-05 21:38:23 UTC
A default font-size is indeed missing. It should be in <style:text-properties> in <style:default-style>. Tested with Version: 6.2.0.0.alpha1+ (x64)
Build ID: e33424dd887cb1a11a3dba2513ef0f4bf93a6dbe
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-01_00:43:29
Locale: de-DE (en_US); Calc: CL
Comment 7 QA Administrators 2019-11-06 03:30:34 UTC Comment hidden (obsolete)
Comment 8 gmolleda 2019-11-06 08:13:43 UTC Comment hidden (obsolete)
Comment 9 gmolleda 2020-08-17 16:46:42 UTC
Reconfirmed: Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
Subprocs. CPU: 4; SO: Linux 4.15; Repres. IU: predet.; VCL: gtk3
Locale: es-ES (eo.UTF-8); Interfaz: es-ES
Calc: threaded
Comment 10 Regina Henschel 2020-09-12 21:42:04 UTC
Workaround; Change font size in style "Default Cell Style". For example change to 12pt. Then change back to 10pt. Make sure in tab 'Organizer' that the 'Contains' section has '10pt'.
Comment 11 Timur 2021-08-03 09:41:13 UTC
Repro LO 6.2 and 7.1. No repro 7.2 and 7.3+. So this seems like WFM.

Now in styles.xml there is font size:
<style:default-style style:family="table-cell">
 <style:paragraph-properties style:tab-stop-distance="1.25cm"/>
 <style:text-properties style:font-name="Liberation Sans" fo:font-size="10pt" fo:language="bs" fo:country="BA" style:font-name-asian="Microsoft YaHei" style:font-size-asian="10pt" style:language-asian="zh" style:country-asian="CN" style:font-name-complex="Mangal" style:font-size-complex="10pt" style:language-complex="hi" style:country-complex="IN"/>
</style:default-style>
Comment 12 Buovjaga 2021-08-03 09:58:03 UTC

*** This bug has been marked as a duplicate of bug 112559 ***