Bug Hunting Session
Bug 106148 - Tooltip is incorrect on some buttons. It shows "□□□". (steps in comment 10)
Summary: Tooltip is incorrect on some buttons. It shows "□□□". (steps in comment 10)
Status: RESOLVED DUPLICATE of bug 108042
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2017-02-23 07:11 UTC by Kamei
Modified: 2018-11-18 14:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (35.91 KB, image/png)
2017-02-23 07:13 UTC, Kamei
Details
screenshot 02 (39.23 KB, image/png)
2017-02-23 07:14 UTC, Kamei
Details
Tooltip can sometimes show correctly. (35.27 KB, image/png)
2017-02-23 09:16 UTC, Kamei
Details
I confirm this issue is occurred on Chinese too. (75.17 KB, image/png)
2017-03-13 01:48 UTC, Kamei
Details
I confirm this issue is occurred on Korean too. (52.32 KB, image/png)
2017-03-13 01:49 UTC, Kamei
Details
Garbled character on Preference Window (248.48 KB, image/png)
2017-06-12 09:04 UTC, Kamei
Details
It is occured on Writer too. (6.70 MB, video/quicktime)
2017-06-12 09:37 UTC, Kamei
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kamei 2017-02-23 07:11:48 UTC
Description:
Tooltip is incorrect on some buttons. It shows "□□□".

Steps to Reproduce:
1.Move mouse cursor to a button like Print.
2.Stop the mouse cursor.
3.Tooltip is shown with "□□ (⌘P)"

Actual Results:  
Tooltip is shown with "□□ (⌘P)"

Expected Results:
"プリント(⌘P)"


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:53.0) Gecko/20100101 Firefox/53.0
Comment 1 Kamei 2017-02-23 07:13:53 UTC
Created attachment 131419 [details]
screenshot
Comment 2 Kamei 2017-02-23 07:14:59 UTC
Created attachment 131420 [details]
screenshot 02
Comment 3 Kamei 2017-02-23 07:16:42 UTC
My Environment is:

Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Mac OS X 10.11.6; UI Render: GL; Layout Engine: new; 
Locale: ja-JP (ja.UTF-8); Calc: group
Comment 4 V Stuart Foote 2017-02-23 08:49:11 UTC
The GUI is dependent on the OS/DE for the fonts used in the user interface. Any chance the default font set on your system does not support the CJK glyphs needed? Are you able to change the default "system" font in the macOS configuration to a font known to have those glyphs?
Comment 5 Kamei 2017-02-23 09:16:03 UTC
Created attachment 131424 [details]
Tooltip can sometimes show correctly.

(In reply to V Stuart Foote from comment #4)

Thank you for your replying!

> Are you able to change the default "system" font in the macOS
> configuration to a font known to have those glyphs?

I think I cannot change the system font with ordinary way on macOS.

Please check the new attached screenshot.
Some tooltip can show correctly.
Comment 6 Kamei 2017-03-13 01:48:44 UTC
Created attachment 131839 [details]
I confirm this issue is occurred on Chinese too.

Can anybody confirm this?
Comment 7 Kamei 2017-03-13 01:49:27 UTC
Created attachment 131840 [details]
I confirm this issue is occurred on Korean too.
Comment 8 Kamei 2017-06-12 09:03:07 UTC
I notice that "□" character is displayed with some special character only.
like "⌘", "⇧", "℃" and more.

And this issue is not only tooltip but Preference Window.
See "Language Setting" > "Asian Layout".
Then you change Language to something except for English.

You can see garbled character.



Version: 5.3.2.2
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 8; OS Version: Mac OS X 10.11.6; UI Render: GL; Layout Engine: new; 
Locale: en-US (ja.UTF-8); Calc: group
Comment 9 Kamei 2017-06-12 09:04:40 UTC
Created attachment 133971 [details]
Garbled character on Preference Window
Comment 10 Kamei 2017-06-12 09:37:41 UTC
Created attachment 133972 [details]
It is occured on Writer too.

I noticed that this issue is occurred on Writer Document too.

1. create new Writer Document
2. change font to Arial
3. Paste this "プリント".
4. You can certainly see "プリント".
5. Paste this "⌘".
6. You can see "□"
Comment 11 Xisco Faulí 2017-11-15 10:42:44 UTC
Moving back to unconfirmed to see if someone can reproduce it...
Comment 12 eisa01 2017-11-15 21:57:55 UTC
This may be related to bug 108042. Did not try to confirm
Comment 13 Buovjaga 2017-11-16 13:32:37 UTC
(In reply to Kamei from comment #10)
> Created attachment 133972 [details]
> It is occured on Writer too.
> 
> I noticed that this issue is occurred on Writer Document too.
> 
> 1. create new Writer Document
> 2. change font to Arial
> 3. Paste this "プリント".
> 4. You can certainly see "プリント".
> 5. Paste this "⌘".
> 6. You can see "□"

No problem for me. Please try with LibreOffice 5.4.3.

Version: 5.4.3.2
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_FI.UTF-8); Calc: group
Comment 14 Kamei 2017-12-06 07:09:05 UTC
Thanks your comment.
But this issue is still reproduced.

In addition, I had installed Japanese Language Pack.
Perhaps, this is important for reproducing this issue.


Version: 5.4.3.2
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 8; OS: Mac OS X 10.11.6; UI render: GL; 
Locale: ja-JP (ja.UTF-8); Calc: group
Comment 15 Buovjaga 2018-01-19 09:32:30 UTC
bug 108042 is newer than this, but let's dupe to it as it was already confirmed

*** This bug has been marked as a duplicate of bug 108042 ***