Download it now!
Bug 106164 - beginning of sentence not capitalized on text with typographical apostrophe
Summary: beginning of sentence not capitalized on text with typographical apostrophe
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All All
: medium minor
Assignee: László Németh
URL:
Whiteboard: target:6.5.0 target:6.4.0.2 target:6.3.5
Keywords: bibisected, bisected, regression
: 100778 129934 (view as bug list)
Depends on:
Blocks: Authors
  Show dependency treegraph
 
Reported: 2017-02-23 20:00 UTC by James Falksen
Modified: 2020-01-11 11:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Falksen 2017-02-23 20:00:19 UTC
Description:
I have an autotext replacement of "didnt"->"didn't".
When this is used at the beginning of a sentence, it is not capitalized.

Steps to Reproduce:
1. set up such an autotext. turn on "capitalize sentences"
2. type "didnt" at the beginning of a sentence
3.

Actual Results:  
this happens with any replace value containing "'".

Expected Results:
"Didn't"


Reproducible: Always

User Profile Reset: No

Additional Info:
instead got "didn't"


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 James Falksen 2017-02-23 20:46:27 UTC
just discovered it has nothing to do with autotext. I began a sentence with "we've" and it did not get capitalized.
Comment 2 Xisco Faulí 2017-02-24 12:59:00 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 880033edde516fc30225005245253293a6a58ba4
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

but not in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)
Comment 4 QA Administrators 2018-03-11 03:40:55 UTC Comment hidden (obsolete)
Comment 5 Caolán McNamara 2018-12-20 16:56:47 UTC

*** This bug has been marked as a duplicate of bug 108423 ***
Comment 6 László Németh 2019-04-02 07:41:18 UTC
The bug 108423 was fixed specifically for the lowercase English word i' -> i’.
Comment 7 Xisco Faulí 2019-04-09 12:07:21 UTC
(In reply to László Németh from comment #6)
> The bug 108423 was fixed specifically for the lowercase English word i' ->
> i’.

Hi László, should we fix this kind of issues in a general way instead of specifically for each case ?
Comment 8 Xisco Faulí 2019-04-09 12:09:02 UTC Comment hidden (obsolete)
Comment 9 László Németh 2019-04-09 15:53:17 UTC
(In reply to Xisco Faulí from comment #7)
> (In reply to László Németh from comment #6)
> > The bug 108423 was fixed specifically for the lowercase English word i' ->
> > i’.
> 
> Hi László, should we fix this kind of issues in a general way instead of
> specifically for each case ?

@Xisco: Yes, it's possible, I'll check it.
Comment 10 László Németh 2019-04-09 15:57:23 UTC
(In reply to Xisco Faulí from comment #8)
> Regression introduced by
> https://gerrit.libreoffice.org/plugins/gitiles/core/+/
> e6fade1ce133039d28369751b77ac8faff6e40cb%5E!

@Xisco: maybe you don't want to reference this SVG commit for the sentence capitalization bug report.
Comment 11 Xisco Faulí 2019-04-09 16:05:18 UTC
ahh my bad. Same mistake again -> https://cgit.freedesktop.org/libreoffice/core/commit/?id=e6fade1ce133039d28369751b77ac8faff6e40cb
Comment 12 Commit Notification 2019-12-21 15:23:22 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f6cf80c81043d84606a5b5f7d93ae958307a16d3

tdf#106164 AutoCorrect: capitalize words with apostrophe

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 László Németh 2019-12-21 15:24:40 UTC
Fixed in master, and started to back port to the upcoming 6.4.

@All: Thanks for your report and help!
Comment 14 Commit Notification 2019-12-21 19:37:34 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/030b7c01dcb2262e5dc73de81dd33e2e24529da2

tdf#106164 AutoCorrect: capitalize words with apostrophe

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-12-24 11:50:42 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/b6d9188c2ea28867c3792c489c646543b381f17d

tdf#106164 AutoCorrect: capitalize words with apostrophe

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 László Németh 2019-12-25 15:26:54 UTC
*** Bug 100778 has been marked as a duplicate of this bug. ***
Comment 17 Xisco Faulí 2019-12-26 10:16:56 UTC
(In reply to James Falksen from comment #1)
> just discovered it has nothing to do with autotext. I began a sentence with
> "we've" and it did not get capitalized.

Verified in

Version: 6.5.0.0.alpha0+
Build ID: 1abfc8e2f677024ea058e96f3133e503ba89ea02
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@László, thanks for fixing this issue!!
Comment 18 Julien Nabet 2020-01-11 11:14:57 UTC
*** Bug 129934 has been marked as a duplicate of this bug. ***