Download it now!
Bug 106204 - Method to assign a background color to a cell or group of cells is inconsistent.
Summary: Method to assign a background color to a cell or group of cells is inconsistent.
Status: RESOLVED DUPLICATE of bug 84579
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2017-02-27 01:04 UTC by Aprax
Modified: 2017-03-05 16:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The issue: What's the background color of cell A3 (30.40 KB, image/png)
2017-03-05 01:53 UTC, Aprax
Details
Format cells is no help, is it chart 2 or orange 3? (53.82 KB, image/png)
2017-03-05 01:54 UTC, Aprax
Details
color adjacent cells and choose the best match (39.89 KB, image/png)
2017-03-05 01:56 UTC, Aprax
Details
Can't see all colors at one time (96.28 KB, image/png)
2017-03-05 01:57 UTC, Aprax
Details
Use scroll bar to see other colors (96.32 KB, image/png)
2017-03-05 01:57 UTC, Aprax
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aprax 2017-02-27 01:04:03 UTC
Select one cell or multiple cells having the same color

1) Toolbar > Background color
	Good - shows the existing color of the cell
	Bad - requires use of a drop down list to see all colors

vs.

2) Right click on the cell > Format cells... > Background color
	Bad - doesn't show the current color of the cell
	Good - shows all possible colors without using a drop down list

Both methods should:
- show the existing color of the cell(s) if they have the same existing color
- show all possible colors without using a drop down list
Comment 1 Buovjaga 2017-03-04 18:13:07 UTC
The format cells dialog *does* show the existing color for a group of cells. Or do you mean it should encircle the color in the palette grid as well?
I notice it does not show a tooltip for the color name either.

I do not understand your reference to a "drop down list to see all colors". If you are referring to the palette drop down that is new in 5.3 for the button, your "2) Good - shows all possible colors without using a drop down list" does not make sense. The new style Area tab as seen in Writer does not yet exist in Calc.
Comment 2 Aprax 2017-03-05 01:52:10 UTC
When language fails, use pictures.

The practical application is to answer the question:
- Which background color is currently in use in a cell?

It is now more difficult to determine than it was before.

01) What's the color in A3?

Using Format cells:
02) This does show all "standard" colors at the same time without a scroll bar (drop down list) but beyond that, it offers no real help at all. 
Is it chart 2 or orange 3? 
These colors are very close but still different and hard to "match" by just looking at the color chart.
03) The only practical way is to color an adjacent cell as chart 2 and then as orange 3 to choose the best match.

Using Background color:
04) This does not show all colors at the same time as seen in Format cells. 
05) It requires use of the scroll bar to "find" chart 2 which is "boxed", which is helpfull but no name is shown unless the cursor hovers over the "box".

Actually I think that the two colors are exactly the same but perhaps I'm slightly color blind. You may be able to distinguish a difference.
Comment 3 Aprax 2017-03-05 01:53:28 UTC
Created attachment 131632 [details]
The issue: What's the background color of cell A3
Comment 4 Aprax 2017-03-05 01:54:56 UTC
Created attachment 131633 [details]
Format cells is no help, is it chart 2 or orange 3?
Comment 5 Aprax 2017-03-05 01:56:17 UTC
Created attachment 131634 [details]
color adjacent cells and choose the best match
Comment 6 Aprax 2017-03-05 01:57:09 UTC
Created attachment 131635 [details]
Can't see all colors at one time
Comment 7 Aprax 2017-03-05 01:57:58 UTC
Created attachment 131636 [details]
Use scroll bar to see other colors
Comment 8 Buovjaga 2017-03-05 08:37:40 UTC
Ok, I think the "Can't see all colors at one time" is just a conscious decision.

Adding design team to CC to inquire about the Format cells dialog: is it planned to bring the new Area tab to Calc?

In the new Area tab, is it planned to show in a tooltip the name of the active and new colours, if they match a named colour?
Comment 9 Aprax 2017-03-05 09:41:50 UTC
(In reply to Buovjaga from comment #8)
> Ok, I think the "Can't see all colors at one time" is just a conscious
> decision.

Ok, how about "It's impossible to see all 143 colors in the active window because the active window is too small and requires scrolling to see other colors, and which is different than the window used in the Format cells > Background tab which shows all 143 colors at the same time without scrolling. 
The Maximum number of colors displayed, i.e. visible at the same time, is 12 columns x 9 rows = 72 leaving 71 or 72 colors not visible depending on the position of the scroll bar." 

I'm curious about your comment that the "... Can't see all colors at one time" title is just a conscious decision." 
Do you mean that, after looking at the window, I come to a point where I have to make a decision about whether I can or cannot see all colors at that instant in time and I then, being in a concious state, make a decision to say "I can't see all the colors at one time" rather than "I can't see all colors at the same time" or some other remark that I might make if I was in an unconcious state?
I would prefer to call it "an observation" which is an instance of viewing and noting a fact, the fact that all colors are....... because that is what I observed (and stated by way of comment; remark).
Comment 10 Heiko Tietze 2017-03-05 10:11:25 UTC
(In reply to Aprax from comment #2)
> 01) What's the color in A3?

There are several ways. The active color has a frame in the color picker on the sidebar or the toolbar, with a tooltip that shows the color name. The swatch 'Recent colors' contains of this color, and also the document colors should list  it (that might be buggy). 

We discussed the question in the design meeting yesterday. The color picker has to scroll down to the active color when its being opened, that's a bug. The other question is how prominent the color name has to be shown. My opinion is simplicity and clean layout before this not so relevant feature - you have the tooltip, while others think the color name (or hex value) is paramount.
 
More issues regarding the color palettes and color picker can be found in bug 104118 and bug 85184 respectively. I make this one a dup of 84579, you are welcome to join the discussion.

(In reply to Buovjaga from comment #8)
> Adding design team to CC to inquire about the Format cells dialog: is it
> planned to bring the new Area tab to Calc?

Of course. Area Fill issues are tracked in bug 103223, dialogs where the new UI is missing in bug 105225.

*** This bug has been marked as a duplicate of bug 84579 ***
Comment 11 Aprax 2017-03-05 16:20:37 UTC
(In reply to Heiko Tietze from comment #10)
> (In reply to Aprax from comment #2)
> > 01) What's the color in A3?
> 
> There are several ways. The active color has a frame in the color picker on
> the sidebar or the toolbar, with a tooltip that shows the color name. The
> swatch 'Recent colors' contains of this color, and also the document colors
> should list  it (that might be buggy). 
> 
> We discussed the question in the design meeting yesterday. The color picker
> has to scroll down to the active color when its being opened, that's a bug.
> The other question is how prominent the color name has to be shown. My
> opinion is simplicity and clean layout before this not so relevant feature -
> you have the tooltip, while others think the color name (or hex value) is
> paramount.
>  
> More issues regarding the color palettes and color picker can be found in
> bug 104118 and bug 85184 respectively. I make this one a dup of 84579, you
> are welcome to join the discussion.
> 
> (In reply to Buovjaga from comment #8)
> > Adding design team to CC to inquire about the Format cells dialog: is it
> > planned to bring the new Area tab to Calc?
> 
> Of course. Area Fill issues are tracked in bug 103223, dialogs where the new
> UI is missing in bug 105225.
> 
> *** This bug has been marked as a duplicate of bug 84579 ***

Thank you for a very useful reply. I will join 84579.

To address points in your reply and effectively close this bug #:
Most of my sheets are the maximum displayable width and the sidebar is inconvenient, I use the toolbar.
I appreciate the recognition of the bug re: scrolling.
My vote would be for elimination of the scroll bar with a bigger window.
I'd be happy with the box around the active color and the hover to see the name.