Bug 106258 - Indexes with chapter+page numbers are losing chapter numbers when updating
Summary: Indexes with chapter+page numbers are losing chapter numbers when updating
Status: RESOLVED DUPLICATE of bug 104315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-01 15:17 UTC by Thomas Lendo
Modified: 2017-03-02 11:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of updated indexes (21.91 KB, image/png)
2017-03-01 15:19 UTC, Thomas Lendo
Details
Example text document with some indexes (321.19 KB, application/vnd.oasis.opendocument.text)
2017-03-01 15:20 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-03-01 15:17:48 UTC
Description:
When you update some indexes (e.g. Illustration index and Index ob tables, but NOT Table of Contents) then the chapter numbers vanish in the index.

Steps to Reproduce:
1. Create an ODF text document with chapter-based indexes for contents, tables, illustrations, etc. in an older version of LibO as 5.3.0.x (e.g. 5.1.4.2 works).
2. Open that file in LibO 5.3.0.3.
3. Update all indexes in that file.

Actual Results:  
The chapter numbers vanish in some indexes.
E.g. "1-2" (1 is the chapter, 2 is the page number) will be "-2".

Expected Results:
The chapter numbers should not vanish.


Reproducible: Always

User Profile Reset: Yes, fresh 5.3.0.3 user profile.

Additional Info:
Tested with LibO version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: de-DE (de_DE); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Comment 1 Thomas Lendo 2017-03-01 15:19:40 UTC
Created attachment 131562 [details]
Screenshot of updated indexes
Comment 2 Thomas Lendo 2017-03-01 15:20:55 UTC
Created attachment 131563 [details]
Example text document with some indexes
Comment 3 LibreTraining 2017-03-01 21:25:48 UTC

Confirmed Bug in LO 5.3.0.3

Works correctly in LO 5.2.5.1

Works correctly in LO 5.4.0.0.alpha+

Version: 5.4.0.0.alpha0+
Build ID: 0999c403a0a7cc9248a1773042ad09fd85004267
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-21_23:15:44
Locale: en-US (en_US); Calc: group
Comment 4 Xisco Faulí 2017-03-02 11:51:11 UTC
it seems like a duplicate of bug 104315.
it should be fixed in coming versions

*** This bug has been marked as a duplicate of bug 104315 ***