Bug 106284 - Sifr icon for "save/save as" not shown as other activated icons
Summary: Sifr icon for "save/save as" not shown as other activated icons
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Adolfo Jayme
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.3
Keywords:
Depends on:
Blocks: Icon-Theme-Sifr
  Show dependency treegraph
 
Reported: 2017-03-02 21:28 UTC by Thomas Lendo
Modified: 2017-05-26 20:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Standard toolbar Sifr icons with a dark theme (19.16 KB, image/png)
2017-03-02 21:31 UTC, Thomas Lendo
Details
Toolbar Sifr icons with a dark theme on Windows (9.97 KB, image/png)
2017-03-20 08:28 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-03-02 21:28:25 UTC
If there is an unsaved content, the Sifr icon for "save/save as.../export..." is not shown as other activated icons in the toolbar in dark themes. The icon itself is bright highlighted but looks "cut" at the edges and not smooth like icons with activated status like spell checker or left alignment of paragraphs.

I know that the "save/save as" icon is different from the other icons I mentioned, nevertheless it should look more excellent as the other icons of the excellent Sifr icon theme do.
Comment 1 Thomas Lendo 2017-03-02 21:31:26 UTC
Created attachment 131586 [details]
Standard toolbar Sifr icons with a dark theme

Test made with LibO version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~trusty1.1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 2 Adolfo Jayme 2017-03-03 04:15:04 UTC
@Matthias, can you look at this when you find the time? Thanks!
Comment 3 Papamatti 2017-03-19 17:57:48 UTC
Could not reproduce this in MS Windows and the icons are also transparent in the sources.
Comment 4 Thomas Lendo 2017-03-20 08:28:31 UTC
Created attachment 132022 [details]
Toolbar Sifr icons with a dark theme on Windows

Not only on Ubuntu Linux, I also reproduced the issue on Windows 10 Pro with activated OpenCL and "Use OpenGL" options.

See atteched image made with Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; Locale: de-DE (de_DE); Calc: CL
New user profile.

Steps to reproduce:

1. Open a Writer document.
2. Go to Tools > Options > LibreOffice > Personalization
3. Activate "Own Theme" and then click at "Select Theme" button.
4. Click at "LibreOffice" button and select the first dark theme ("Office 2003 for LibreOffice" was my first shown theme).
5. Click OK and OK.
6. Look at the Save/Save As icon.
7. Type a string into the document so that LibreOffice recognizes that there are unsaved changes.

Actual result:

The Save/Save As icon is white highlighted.

Expected result:

Same appearance as other "active" icons like "Toggle Formatting Marks" and "Align Left" (both shown with dark blue background in the toolbar at attached image).
Comment 5 Commit Notification 2017-03-21 05:29:14 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0a8612f8b893b9510e083dbb9f01077d0ba1c017

tdf#106284 Sifr icon accidentally included an opaque background

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Adolfo Jayme 2017-03-21 05:40:48 UTC
I can’t push to the Sifr repo at GitHub.com/libodesign, but I reexported the icon from saveexport.svg and pushed the result to LibreOffice (only the 16 × 16 icon was affected). I’ll backport this change to 5.3.3 as well.
Comment 7 Papamatti 2017-03-21 06:47:52 UTC
Ok, thank you. Sorry my fault, forgot to disable the "cmd" layer before exporting in inkscape.
Comment 8 Commit Notification 2017-03-21 08:00:56 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d7500b1e563c9d15a784e6ee834bab3210d5faaa&h=libreoffice-5-3

tdf#106284 Sifr icon accidentally included an opaque background

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Thomas Lendo 2017-03-21 08:08:41 UTC
Thank you both very much!
I forgot to report that I'm using small toolbar icons and to test it with the "Automatic" (larger) size.