Bug 106291 - A specific DOC with table having horizontally merged cells is IMPORTED incorrectly
Summary: A specific DOC with table having horizontally merged cells is IMPORTED incorr...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:5.4.0
Keywords: filter:doc
Depends on:
Blocks:
 
Reported: 2017-03-03 08:34 UTC by Mike Kaganski
Modified: 2017-03-05 19:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A sample DOC with a 1x3 table where all 3 cells are merged (23.50 KB, application/msword)
2017-03-03 08:34 UTC, Mike Kaganski
Details
A comparison of LO and MS Word (108.79 KB, image/png)
2017-03-03 08:46 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2017-03-03 08:34:17 UTC
Created attachment 131592 [details]
A sample DOC with a 1x3 table where all 3 cells are merged

Attached file contains only one table with 1 row and 3 columns. Its cells are all merged. The total width of resulting single merged cell is ~15.62 cm.

When opened with MS Word, it is shown as described above. LO (all versions including 5.3.1.1) and OOo 3.3.0 open it with the table with zero height and 1/3 width (shown as horizontal line at top left corner).
Comment 1 Mike Kaganski 2017-03-03 08:46:05 UTC
Created attachment 131593 [details]
A comparison of LO and MS Word
Comment 2 Mike Kaganski 2017-03-03 08:47:36 UTC
A patch is submitted for review: https://gerrit.libreoffice.org/34820
Comment 3 Xisco Faulí 2017-03-03 09:39:29 UTC
if patch is in gerrit, moving to NEW then...
Comment 4 Julien Nabet 2017-03-03 10:26:07 UTC
Let's put this one to ASSIGNED Mike since you assigned yourself.
Comment 5 Commit Notification 2017-03-03 13:41:49 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb2a3df2d5b5a01aa58fb3567686e50762186036

tdf#106291: WW8 import: Properly treat column spans

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.