Bug 106308 - Table formatted with rows alterning their color including last row
Summary: Table formatted with rows alterning their color including last row
Status: RESOLVED DUPLICATE of bug 101349
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2017-03-03 21:07 UTC by Thomas Lendo
Modified: 2017-03-04 20:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Suggestion for a checkbox to deactivate the total row in a table style (41.24 KB, image/png)
2017-03-03 21:10 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-03-03 21:07:59 UTC
The existing AutoFormat styles for tables in Writer are focused on financial issues and use a total row (sum row). But sometimes you don't need a total row and the last row should be styled than the other rows (e.g. with alternating colors).

The table styles should be configurable
* to save a table style without a total row and
* to assign a table style to an existing table without a total row - the simplest way would be a checkbox in the formatting area in the bottom of the AutoFormat dialog window.


Actual result:

- - - -
Header row
- - - -
bright row
- - - -
dark row
- - - -
bright row
- - - -
dark row
- - - -
total row
- - - -

Desired result if no total row is necessary:

- - - -
Header row
- - - -
bright row
- - - -
dark row
- - - -
bright row
- - - -
dark row
- - - -
BRIGHT row
- - - -
Comment 1 Thomas Lendo 2017-03-03 21:10:26 UTC
Created attachment 131616 [details]
Suggestion for a checkbox to deactivate the total row in a table style
Comment 2 Heiko Tietze 2017-03-04 20:27:49 UTC
What you show in the screenshot is the legacy autoformat dialog, which will become obsolete when the real table styles overcome the experimental state. The request is valid but not as a switch, rather an extra style. Work is ongoing, a survey being planned, and actually we have a couple of table styles that do not modify the last line. Despite the predefined styles it's supposed to be a user-defined feature. You are responsible for your styles (IIRC, the legacy dialog was able to do what you want). Unfortunately it's not working yet, see bug 105933. And there are some other issues, the bug 101756 is the respective meta ticket.

*** This bug has been marked as a duplicate of bug 101349 ***