Download it now!
Bug 106332 - Impress do not allow open edit password-protected PowerPoint presentations in "read-only" mode
Summary: Impress do not allow open edit password-protected PowerPoint presentations in...
Status: RESOLVED DUPLICATE of bug 38370
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-05 10:16 UTC by Sebastian
Modified: 2017-03-08 11:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
MS Office pps edit password protected. (7.57 MB, application/x-ole-storage)
2017-03-05 10:24 UTC, Sebastian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian 2017-03-05 10:16:38 UTC
Description:
When I open some MS Office pps or ppsx documents which are not password protected Libre Office displays an error window with text: "Read Error: Opening password protected Power Point presentations is not possible."

But the pps in question is not password protected and opens in MS Office normally with out asking for password.

Steps to Reproduce:
1.Take some pps document Libre Office says it is password protected and can not open it.
2.Open it in MS Office in normal way without password dialog.
3.

Actual Results:  
Libre Office displays Error window with text:"Read Error: Opening password protected Power Point presentations is not possible."

Expected Results:
PPS document should have opened normally.


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Sebastian 2017-03-05 10:24:27 UTC
Created attachment 131644 [details]
MS Office pps edit password protected.
Comment 2 Sebastian 2017-03-05 10:36:35 UTC
Reproduced in LO 5.2.2.2.
Comment 3 Sebastian 2017-03-05 10:43:16 UTC
It is a edit password protected pps. But LO should open it in read only mode.
Comment 4 Sebastian 2017-03-05 11:17:09 UTC
(In reply to Sebastian from comment #3)
> It is a edit password protected pps. But LO should open it in read only mode.

(In reply to Sebastian from comment #2)
> Reproduced in LO 5.2.2.2.

Also reproduced in LO 5.3.0.3
Comment 5 Sebastian 2017-03-05 12:13:06 UTC
PPS is password protected against edition. But Libre Office can not open it in read only mode, which is a serious drawback. LO should be able to open doucument in read only mode even if they are protected against edition.
Comment 6 Xisco Faulí 2017-03-08 11:24:41 UTC
Hello,
it has already been reported in bug 38370.
Regards

*** This bug has been marked as a duplicate of bug 38370 ***