Download it now!
Bug 106384 - Large content in section which is in table cell is cut
Summary: Large content in section which is in table cell is cut
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2017-03-07 12:14 UTC by Robert Nemet
Modified: 2020-01-30 14:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Document to reproduce bug. (15.54 KB, application/vnd.oasis.opendocument.text)
2017-03-07 12:15 UTC, Robert Nemet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Nemet 2017-03-07 12:14:00 UTC
Description:
I have a table ( for example 4 x 4 ) and inside one of table cells as cell content I have section. If there is a lot of text, large content, in the section: row containing this section goes on next page. If content of section can not fit page then content is cut, section does not expand on next page.

Expected: Section and table is extended to next page so whole section content is visible.

OS: Win7
LibreOffice Version: 5.0.6.3

Steps to Reproduce:
1.Create table
2.Insert some text in any table cell and wrap it in section 
3.Add a lot of text to that section.

Actual Results:  
Content in section is cut. Section do not span on next page.

Expected Results:
Section and table is extended to next page so whole section content is visible.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 Robert Nemet 2017-03-07 12:15:42 UTC
Created attachment 131696 [details]
Document to reproduce bug.
Comment 2 Svante Schubert 2017-03-07 12:31:22 UTC
I can confirm the problem. Even if a footer was added with text, the table is continuing over the footer and the page margin and even inbetween the pages..
Obviously a bug..

Tested follwing with Libreoffice:
Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: de-DE (de_DE); Calc: group


Aside the document is valid ODF 1.2 (aside the usual proprietary application attributes). 
Tested online via http://odf-validator.rhcloud.com/
Comment 3 Xisco Faulí 2017-03-07 16:19:15 UTC
*** Bug 106390 has been marked as a duplicate of this bug. ***
Comment 4 kirchhoffb 2017-03-13 16:14:43 UTC
I don't think this issue and tdf#131696 are duplicates, even though they look similar. In this case, the table cell contains a section, without any attributes like "Allow table split across pages and columns" and "Allow row break across pages and columns" being set for the table.
Comment 5 kirchhoffb 2017-03-13 16:15:05 UTC Comment hidden (obsolete)
Comment 6 Michael Stahl (CIB) 2017-03-27 12:36:36 UTC
on Linux, can reproduce the layout bug on every version all the way back to OOo 3.0.1
=> not a regression
Comment 7 QA Administrators 2018-06-30 02:40:51 UTC Comment hidden (obsolete)
Comment 8 Timur 2020-01-30 14:50:43 UTC
Repro LO 5.0 2 pages, 6.0.7 and 7.0+ 7 pages.
I'll close as WFM.