Bug Hunting Session
Bug 106393 - VIEWING: Text doesn't fit in cells when zooming
Summary: VIEWING: Text doesn't fit in cells when zooming
Status: RESOLVED DUPLICATE of bug 108638
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-03-07 16:54 UTC by Thomas Lendo
Modified: 2017-09-07 20:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test spreadsheet with text (30.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-03-07 16:56 UTC, Thomas Lendo
Details
Screenshot showing zoom level 200 percent with activated spell checking (212.46 KB, image/png)
2017-03-07 16:57 UTC, Thomas Lendo
Details
Above test spreadsheet with Calc option "Use printer metrics for text formatting" on and off (199.64 KB, image/png)
2017-03-08 07:54 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-03-07 16:54:04 UTC
The zoom level changes the presentation of fonts of text in calc spreadsheets and that has an effect on the cell height.

The effect is much more intrusive if spell checking is activated and text is underlined.

Steps to reproduce:

1. Open a Calc spreadsheet.
2. Write text in some consecutive rows.
3. Optimize the height of the rows at zoom level 100 %. (You can do that by highlighting all rows and then double-clicking between two rows or by highlighting all rows and then right-click at the row numbering bar using "Optimal Height...".)
4. Change zoom level to 200 %.
5. Do the same as in step 3.

Actual result:
The row height will be adjusted to the text presentation in your current zoom level.

Expected result:
Nothing should happen because zooming shouldn't result in changing cell parameters.


Tested with:

LibOersion: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: de-DE (de_DE); Calc: CL

It works well in LibO version 5.1.4.2.
Comment 1 Thomas Lendo 2017-03-07 16:56:19 UTC
Created attachment 131706 [details]
Test spreadsheet with text
Comment 2 Thomas Lendo 2017-03-07 16:57:58 UTC
Created attachment 131708 [details]
Screenshot showing zoom level 200 percent with activated spell checking
Comment 3 m.a.riosv 2017-03-08 00:24:30 UTC
Please test changing:
Menu/Tools/Options/LibreOffice/View - Graphics outpug - OpenGL.

Menu/Tools/Options/LibreOffice calc/General - Use printer metrics.
Comment 4 Thomas Lendo 2017-03-08 07:54:29 UTC
Created attachment 131746 [details]
Above test spreadsheet with Calc option "Use printer metrics for text formatting" on and off

m.a.riosv, thank you. Changing the option "Use OpenGL for all rendering" has no effect. But changing the Calc specific option "Use printer metrics for text formatting" shows a correct text layout after zooming.

FYI: I'm using a fresh user profile with LiboO 5.3.0.3.

Changing printers (plotters, laser printer, PDF printers) has no effect whether "Use printer metrics for text formatting" is activated or not.

In my 5.1.4.2 LibO installation the option "Use printer metrics for text formatting" never was activated and it still works well.

Is this intended or a bug/regression?
Comment 5 Buovjaga 2017-03-13 12:31:27 UTC
(In reply to Thomas Lendo from comment #0)
> The effect is much more intrusive if spell checking is activated and text is
> underlined.

How do you get it so the redlining appears on all cells without text editing? I only get it when I activate editing of a cell.
Comment 6 Thomas Lendo 2017-03-13 22:04:28 UTC
(In reply to Buovjaga from comment #5)
> (In reply to Thomas Lendo from comment #0)
> > The effect is much more intrusive if spell checking is activated and text is
> > underlined.
> 
> How do you get it so the redlining appears on all cells without text
> editing? I only get it when I activate editing of a cell.

I don't know. Language locale setting is set in my profile. Redlining is the default behavior in my personal profile and my 5.3 test profile on Windows and Ubuntu Linux regardless whether I edit a cell or not.
Comment 7 Buovjaga 2017-03-20 15:46:58 UTC
Do you think this is the same as bug 56028?
Comment 8 Thomas Lendo 2017-03-20 21:05:28 UTC
(In reply to Buovjaga from comment #7)
> Do you think this is the same as bug 56028?

I thought the same today. But maybe it's only the same "meta-cause" because the bug I described here occurs since version 5.3 (regression of bug 55469?).
Comment 9 OfficeUser 2017-05-23 10:31:55 UTC

*** This bug has been marked as a duplicate of bug 106111 ***
Comment 10 OfficeUser 2017-05-23 10:33:19 UTC
Perhaps related with bug 106111.
Comment 11 OfficeUser 2017-05-24 10:59:30 UTC
I set this one as duplicate of Bug 106111 because I think it has the same root cause.

IMHO Calc needs fundamental revision in this scaling and rendering area.

*** This bug has been marked as a duplicate of bug 106111 ***
Comment 12 OfficeUser 2017-05-24 11:04:54 UTC
(In reply to Thomas Lendo from comment #4)
> Created attachment 131746 [details]
> Above test spreadsheet with Calc option "Use printer metrics for text
> formatting" on and off
> 
> m.a.riosv, thank you. Changing the option "Use OpenGL for all rendering" has
> no effect. But changing the Calc specific option "Use printer metrics for
> text formatting" shows a correct text layout after zooming.
> 
> FYI: I'm using a fresh user profile with LiboO 5.3.0.3.
> 
> Changing printers (plotters, laser printer, PDF printers) has no effect
> whether "Use printer metrics for text formatting" is activated or not.
> 
> In my 5.1.4.2 LibO installation the option "Use printer metrics for text
> formatting" never was activated and it still works well.
> 
> Is this intended or a bug/regression?

Regression introduced by:

author	Khaled Hosny <khaledhosny@eglug.org>	2016-11-09 13:22:43 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2016-11-22 15:32:11 (GMT)
commit	34d7602954d4483b3bc9db700e7df2c15348947a (patch)
tree	8dcfb93fc29815fd89481a7840d64d6c187534db
parent	c855aec445628f96d3d32cfde6efd4e51e4489c9 (diff)
tdf#55469 Consistent line spacing across platforms

Adding Cc: to Khaled Hosny
Comment 13 OfficeUser 2017-09-07 20:27:22 UTC

*** This bug has been marked as a duplicate of bug 108638 ***