Download it now!
Bug 106474 - Paste into Calc Spreadsheet gives AppHang
Summary: Paste into Calc Spreadsheet gives AppHang
Status: RESOLVED DUPLICATE of bug 48381
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-10 11:01 UTC by brodders
Modified: 2017-04-28 05:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brodders 2017-03-10 11:01:31 UTC
Hi,

Version is 5.3.0.3 (current release, but not listed in Versions!).

With Draw open, working on a Calc Spreadsheet. Past of a top-left corner copy of an existing sheet (mostly text, c. 50 lines) into a new sheet => application hangs forever. Windows used to kill LO, which gave this report:

Description:
  A problem caused this program to stop interacting with Windows.

Problem signature:
  Problem Event Name:	AppHangB1
  Application Name:	soffice.bin
  Application Version:	5.3.0.3
  Application Timestamp:	588c549e
  Hang Signature:	1eb8
  Hang Type:	6665
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	2057
  Additional Hang Signature 1:	1eb8c1868664168d065cd91fd1298d19
  Additional Hang Signature 2:	3373
  Additional Hang Signature 3:	3373f5f16cbfdcba037e53405d43ac41
  Additional Hang Signature 4:	1eb8
  Additional Hang Signature 5:	1eb8c1868664168d065cd91fd1298d19
  Additional Hang Signature 6:	3373
  Additional Hang Signature 7:	3373f5f16cbfdcba037e53405d43ac41

Next LO startup gives: File recovery, normal operation. Could cut / paste a sheet.
Comment 1 Xisco Faulí 2017-03-10 11:53:57 UTC Comment hidden (obsolete)
Comment 2 Mike Palmer 2017-04-19 22:55:27 UTC
I can duplicate this problem every time. 
1) Select and copy a block of many rows and columns of data in a spreadsheet.
2) In another spreadsheet, select column A and Paste.
LibreOffice hangs.

The reason it hangs is because of the replication feature of LibreOffice Calc. When you select an area in the target spreadsheet that is larger than the block of rows and columns being pasted, LibreOffice Calc replicates the source block as many times as needed to fill the target block.

If you select column A row 1 the problem does not occur. But since you selected column A and column A has 1,048,576 rows, the paste operation is repeated a million times, which on some computers may take a couple of days to complete.
Comment 3 Buovjaga 2017-04-27 17:41:24 UTC
(In reply to Mike Palmer from comment #2)
> I can duplicate this problem every time. 
> 1) Select and copy a block of many rows and columns of data in a spreadsheet.
> 2) In another spreadsheet, select column A and Paste.
> LibreOffice hangs.

brodders: is this how you did it?
Comment 4 brodders 2017-04-27 21:57:15 UTC
I found my very own version of this... and didn't wait a couple of days to find out if paste worked.

Will say Yes, this is the bug.

Seen this in LO / OO since 2010 in various forms (takes ages to paste)

:)
brodders
Comment 5 Buovjaga 2017-04-28 05:19:11 UTC
(In reply to brodders from comment #4)
> I found my very own version of this... and didn't wait a couple of days to
> find out if paste worked.
> 
> Will say Yes, this is the bug.

Ok, then let's close as duplicate of a certain general bug.

*** This bug has been marked as a duplicate of bug 48381 ***