Download it now!
Bug 106485 - Semi-transparent Notebookbar
Summary: Semi-transparent Notebookbar
Status: RESOLVED DUPLICATE of bug 108145
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Theming
  Show dependency treegraph
 
Reported: 2017-03-10 22:11 UTC by pieter kristensen
Modified: 2018-10-23 19:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
OS fills space in libreoffice. (58.04 KB, image/jpeg)
2017-03-10 22:11 UTC, pieter kristensen
Details
5.4 alpha 1 with persona (128.12 KB, image/png)
2017-04-18 16:33 UTC, pieter kristensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pieter kristensen 2017-03-10 22:11:26 UTC
Created attachment 131807 [details]
OS fills space in libreoffice.

Just an idea... Why can't the os fill space that is not really used in LibreOffice? All sytems have some sort of "panel". 
It would be nice to let those systems paint the "hole" in the UI of LibreOffice. In the case op the attachment that is Neon KDE. But all systems I can think of have such a panel. Windows, OSX, Linuxes etc. I made a mockup...
See attachment
Comment 1 Heiko Tietze 2017-03-11 09:32:47 UTC
You may have Windows 10 in mind or maybe also Unity who make the window decoration semi-transparent. But I'm not aware if an application does it for the content area, at least not by default. Anyway, let's add this to the ideas for the Notebookbar.

White space is usually understood as room between elements, in most cases intensionally left empty: https://en.wikipedia.org/wiki/White_space_(visual_arts); changed the topic accordingly.
Comment 2 pieter kristensen 2017-03-11 20:15:10 UTC
My idea was to bring some "air" in de ui of LibreOffice. And to do this by re-using the the decoration of the panel. That way it would not be adding another strange element.
Comment 3 pieter kristensen 2017-04-18 16:33:11 UTC
Created attachment 132657 [details]
5.4 alpha 1 with persona

In my opinion LO deserves something more refined/cool.
Comment 4 Heiko Tietze 2017-04-19 07:39:07 UTC
(In reply to pieter kristensen from comment #3)
> Created attachment 132657 [details]
> 5.4 alpha 1 with persona
> 
> In my opinion LO deserves something more refined/cool.

Where is the thumbs-up button? Great work :-)
Comment 5 andreas_k 2017-04-19 07:58:19 UTC
with persona you can do all those things in a very, very easy way. I'm thinking more of to define in glade the background color, transparancy of different widgets, so that you can say I'd like to have a color, a transparent background, a picture, gradient, ...

with the implementation of persona I'm happy (the UI dialog could be improved).
Comment 6 pieter kristensen 2017-04-19 09:44:47 UTC
I totally agree with you Andreas. In the second attachment (5.4 alpha 1 with persona) everything is just colored. In my opinion this is a nice start but there should be more refinement. Like in my mockup of attachment 1 (OS fills space in libreoffice). 
Libreoffice deserves to look handsome.
Comment 7 andreas_k 2018-10-23 19:28:29 UTC

*** This bug has been marked as a duplicate of bug 108145 ***
Comment 8 andreas_k 2018-10-23 19:34:09 UTC
when bug 108145 is fixed you can do it with personas.

with 6.2 we have 6 preinstalled personas themes if you like, submit an personas theme.