Bug 106507 - Add 4 more default bullet types to toolbar split button and dialog
Summary: Add 4 more default bullet types to toolbar split button and dialog
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Split-Group-Buttons Numbering-Formats
  Show dependency treegraph
 
Reported: 2017-03-12 10:22 UTC by Gerry
Modified: 2021-03-04 09:07 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Mockup of extending bullets formatting toolbar with 4 additional default bullet types (.png image) (39.41 KB, image/png)
2017-03-12 10:22 UTC, Gerry
Details
PDF of four new default bullet types (export from Writer .odt) (38.86 KB, application/pdf)
2017-03-12 11:14 UTC, Gerry
Details
.odt with Four new default bullet types (Writer document) (14.32 KB, application/vnd.oasis.opendocument.text)
2017-03-12 11:16 UTC, Gerry
Details
Bullet Dialog for Images (28.26 KB, image/png)
2021-03-03 09:03 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2017-03-12 10:22:10 UTC
Created attachment 131826 [details]
Mockup of extending bullets formatting toolbar with 4 additional default bullet types (.png image)

Currently, the default set of bullet types for lists in LibreOffice Writer (and Impress) is quite limited and the default set does not meet typographic standards. Currently, the bullets formatting toolbar shows 8 default bullet types (2 rows x 4 bullet types).

This is an enhancement request to add one more row for 4 more default bullet types to the bullet formatting toolbar. I added a mockup .png to this bug entry, how the enhancement could look like. 

Specifically, please add following default bullet types:

– (U+2013) "Halbgeviertstrich" (in English: en dash / en rule)
‐ (U+2010) "Divis" (in English: hyphen)
► (U+25BA)
→ (U+2192)

Please note that the first dash (U+2013) in above list is a typographic standard (e.g. in Germany) and - in fact - very frequently used. 

I assume that this enhancement is an easy hack and low-hanging fruit, which IMHO would benefit many users.

P.S. Please also see the second attachment (.odt) how the suggested bullet types look in LibreOffice Writer (they look better than in above list due to the font used here in Bugzilla)
Comment 1 Gerry 2017-03-12 11:04:00 UTC
Small correction to bug description:

The Unicode code of the third suggested bullet type should be U+25B8 (and NOT U+25BA)!

The default font "Cantarell" for lists in LibreOffice supports the unicode character U+25B8.
Comment 2 Gerry 2017-03-12 11:14:47 UTC
Created attachment 131827 [details]
PDF of four new default bullet types (export from Writer .odt)
Comment 3 Gerry 2017-03-12 11:16:11 UTC
Created attachment 131828 [details]
.odt with Four new default bullet types (Writer document)
Comment 4 V Stuart Foote 2017-03-12 18:19:22 UTC
Not a fan as presented.

With the Format -> Bullets and Numbering dialog the Bullet tab (along with Numbering, Outline) currently holds 8 sample tiles at a "page" layout ratio showing 3 bulleted samples.

Because we would not change the dimensions of the Dialog, the layout for the Bullets tab would have to be adjusted to fit more than 8 samples in the same frame. This is how the Image/Linked graphic tab is configured.

So the Bullets tab of the dialog could be changed to add an extra rows of 4 as in the Image tab, perhaps also including a button action for selecting and sizing a glyph via the Special Character dialog.

But, as the dialog functions now, any one sample tile and corresponding style can be adjusted from the Customize dialog (either bullets, numbering, outline or Image/linked graphic).

So this is strictly a request to change the default 8 tiles to having more bullet styles show--it is not a functional requirement as you can already customize the bullet style once applied to use any glyph(s) from any font.

As an aside, the glyphs for the currently displayed bullets are all draw from OpenSymbol font not Cantarell. And when customizing bullets the Special Character dialog should be opening to OpenSymbol--but is incorrectly opening to a system font (Segoe UI in my case on Windows 10). Just opened see also bug 106515

=-ref-=
http://opengrok.libreoffice.org/xref/core/svx/source/dialog/svxbmpnumvalueset.cxx#379
Comment 5 Gerry 2017-03-12 18:44:59 UTC
(In reply to V Stuart Foote from comment #4)

Thanks a lot Stuart for looking into the bug and for the technical description.

Do I understand correctly that you wouldn't see a technical problem with the addition of the four more default bullet types to the bullet split button of the formatting toolbar?

But, as you describe, the problem you describe appears in the Format -> Bullets and Numbering dialog. Wouldn't it be possible to add a vertical scrollbar to the bullet tab in that dialog to cater for the four new bullet types? You find such a vertical scrollbar in the Format -> Bullets and Numbering -> Image tab. Would that be a solution?
Comment 6 V Stuart Foote 2017-03-12 19:46:38 UTC
(In reply to Gerry from comment #5)
> (In reply to V Stuart Foote from comment #4)
> Do I understand correctly that you wouldn't see a technical problem with the
> addition of the four more default bullet types to the bullet split button of
> the formatting toolbar?
> 
> But, as you describe, the problem you describe appears in the Format ->
> Bullets and Numbering dialog. Wouldn't it be possible to add a vertical
> scrollbar to the bullet tab in that dialog to cater for the four new bullet
> types? You find such a vertical scrollbar in the Format -> Bullets and
> Numbering -> Image tab. Would that be a solution?

Sure, we could refactor from a fixed list of 8 styles, and change the dimensions of the tiles for Bullet, and add a scroll bar if there were more than one additional row.

But we'd have to deal with providing tooltips.  The Image selection  simply links to path for the SVG/GIF/PNG extracted from the LO share\Gallery

As is, tool tips for the existing are a mess, current check Mark bullets shows the "✗" Ballot X (U+2717), while Tick mark bullets shows the "✔" Heavy Check Mark (U+2714).

I'm just not sure that we gain anything, some simple corrections here (even add your preferred U+2013 EN DASH to the Tick mark default) rather that complete refactoring just to add another row.

=-ref-=
http://opengrok.libreoffice.org/xref/core/svx/source/dialog/svxbmpnumvalueset.src#22
Comment 7 Heiko Tietze 2017-03-12 20:29:06 UTC
(In reply to V Stuart Foote from comment #4)
> With the Format -> Bullets and Numbering dialog the Bullet tab (along with
> Numbering, Outline) currently holds 8 sample tiles at a "page" layout ratio
> showing 3 bulleted samples.

Different characters for bullets can be entered at the customization tab. But the default, better called "quick selection", remains as it is. That's awkward since we do not want to predetermine a certain look and feel. So my suggestion would be to rework this dialog and have a selection/modification approach similar to what we did at the area fill style. (Would bet there is a ticket for this idea.)

Anyway, I like the “Halbgeviertstrich” since it contributes to the typographical standardization.
Comment 8 Yousuf Philips (jay) (retired) 2017-06-22 16:30:37 UTC
(In reply to Gerry from comment #0)
> – (U+2013) "Halbgeviertstrich" (in English: en dash / en rule)
> ‐ (U+2010) "Divis" (in English: hyphen)

TextEdit and iWork Pages have a dash preset, though Pages uses U+2D.

> ► (U+25BA)

iWork Pages has a similar fully filled right arrow with a stem.

> → (U+2192)

iWork Pages has a similar right arrow with a stem, though it is thicker.

We definitely need a better set of defaults, which should be discussed as a whole as in bug 108697.
Comment 9 S.Zosgornik 2021-03-01 21:04:14 UTC
In case you decide to rearrange the Bullets toolbar and dialog tab you should also rearrange the numbering toolbar and dialog tab for consistency.

Maybe it's better to just replace lesser used defaults, like diamond and square for dash and hyphen and the existing pointing arrows for ► and → ?
Comment 10 andreas_k 2021-03-03 09:03:22 UTC
Created attachment 170193 [details]
Bullet Dialog for Images

Images already has a 4x3 grid (and many more presets, which I would remove)

maybe you can have the same layout at the other tabs. And please add also the customize button from image tab. I know it's all available in the customize tab but than it's consistent and it's faster to change the bullets, ... stuff
Comment 11 Heiko Tietze 2021-03-04 09:06:52 UTC
We discussed this topic in the design meeting.

   + more items dont solve the issue of bad presets and configurability
     (neither when improving the presets)
   + preferably we have a kind of favorite function and users can pick 
     the best eight out of unlimited and self-made list styles
   + small-screen users want small widgets
   + no objection when the bullets are improved
   + better revamp the dialog (see bug 120905 and bug 140612)

Feel free to reopen, of course.