Download it now!
Bug 106516 - Start of week does not come from locale in conditional formatting
Summary: Start of week does not come from locale in conditional formatting
Status: RESOLVED DUPLICATE of bug 70551
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2017-03-12 20:43 UTC by Aron Budea
Modified: 2017-03-13 04:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (34.54 KB, image/png)
2017-03-12 20:43 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-03-12 20:43:17 UTC
Created attachment 131836 [details]
Screenshot

In an empty spreadsheet I set A1-A20 to 2017-03-01 to 03-20, and set conditional formatting with condition: Date is / This week / Apply Style: Warning. This colors text in the relevant cells red.
Today is a beautiful Sunday (2017-03-12), and my locale is set to Hungarian (relevant detail: start of the week is Monday).

Bug: Calc considers week from Sunday to Saturday instead of Monday to Sunday (based on locale). See cells A12-A18 in attached screenshot.

Markus' comment from IRC:
<@moggi> bearon: good point with sunday vs monday, can you open a bug report? it is hard coded in the code
Comment 1 Aron Budea 2017-03-12 20:46:56 UTC
First version "Date is" option is available from is 4.0.0.3. Also tested with 5.3.1.2.
Comment 2 Cor Nouws 2017-03-12 21:17:04 UTC
Hey Aron,

Looks as bug 70551.

*** This bug has been marked as a duplicate of bug 70551 ***
Comment 3 Aron Budea 2017-03-13 04:12:38 UTC
Hey Cor! How certain are you about these two bugs being the same? I was a bit surprised to find that WEEKS() is an add-in function (not sure what that means), and not part of the standard date/time functions.