Bug 106534 - Color set/palette for charts missing since reorganization of color palettes
Summary: Color set/palette for charts missing since reorganization of color palettes
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0.1
Keywords: bibisected, bisected, needsUXEval, regression
Depends on:
Blocks: Chart Color-Palettes
  Show dependency treegraph
 
Reported: 2017-03-14 15:00 UTC by Thomas Lendo
Modified: 2017-06-23 23:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer document with chart in standard colors (LibO 5.1.4.2) (16.04 KB, application/vnd.oasis.opendocument.text)
2017-03-14 15:00 UTC, Thomas Lendo
Details
Default chart color set in LibO 5.1.4.2 (and older versions) (33.45 KB, image/png)
2017-03-14 15:02 UTC, Thomas Lendo
Details
Chart colors not available in color palettes of LibO 5.3 (52.46 KB, image/png)
2017-03-14 15:04 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-03-14 15:00:27 UTC
Created attachment 131882 [details]
Writer document with chart in standard colors (LibO 5.1.4.2)

Color set/palette for charts is missing since reorganization of color palettes. Now you can't select a color of the pre-defined color set in an existing palette to resort the order of colors or whatever.

The chart color set had 12 colors (Chart 1 to Chart 12).

First suggestion for a solution:
A Chart palette could be introduced, which could be easily changed if the chart color set will be changed in the future.

Second suggestion for a solution:
Another pretty colors from Standard palette (or another palette) could be used as default chart color set.
Comment 1 Thomas Lendo 2017-03-14 15:02:23 UTC
Created attachment 131883 [details]
Default chart color set in LibO 5.1.4.2 (and older versions)

First color (Chart 1, in German: Diagramm 1) is selected and highlighted in the color list.
Comment 2 Thomas Lendo 2017-03-14 15:04:18 UTC
Created attachment 131884 [details]
Chart colors not available in color palettes of LibO 5.3

First color (Chart 1, in German: Diagramm 1) is selected but there is no equivalent in the color palettes of LibO anymore.
Comment 3 Xisco Faulí 2017-03-14 15:05:48 UTC
this seems a duplicate of bug 105225

*** This bug has been marked as a duplicate of bug 105225 ***
Comment 4 Thomas Lendo 2017-03-14 17:45:25 UTC
Xisco, I thought bug 105225 is for accessing color palettes. This bug covers the fact that there are no colors or no color palette for charts anymore. Did I misunderstand the other bug?
Comment 5 Katarina Behrens (CIB) 2017-03-15 08:29:05 UTC
This is indeed not a duplicate. 

Chart colours were removed without replacement from standard colour palette in https://cgit.freedesktop.org/libreoffice/core/commit/?id=765826abcaa441d4d90ffbe75bc3c626c42e639b

Chart module uses legacy colour pickers all over the place which only show colours from standard palette, but even if different palettes were available (replacing legacy pickers with modern ones), chart users still have effectively no access to those colours because they exist in no other palette.

But hey, that's UX improvement for you </heavy_irony>
Comment 6 Thomas Lendo 2017-04-27 23:10:03 UTC
Adding keyword needsUXEval because user should be able to reuse the chart default colors, so this is a UX and design issue.

Idea: A chart color palette should be introduced. Or another idea to handle that?
Comment 7 Heiko Tietze 2017-04-28 08:52:13 UTC
Another palette only adds confusion as we have today quite many different variants. I'd rather go with the standard palette and select new colors. Plus, we should provide common access to colors and palettes (bug 105225) and could offer the old chart palette as extension (if this one isn't the same as the old standard palette).
Comment 8 Heiko Tietze 2017-05-19 12:44:58 UTC
Colors adjusted as close as possible to the old design. https://gerrit.libreoffice.org/#/c/37819/
Comment 9 Heiko Tietze 2017-05-19 18:29:49 UTC
(In reply to Heiko Tietze from comment #8)
> Colors adjusted as close as possible to the old design.
> https://gerrit.libreoffice.org/#/c/37819/

The patch was refused favoring a new palette (discussion also on Telegram). As I voted against that approach because adding various palettes contradicts our previous work I'm out here.
Comment 10 Yousuf Philips (jay) 2017-05-22 04:46:49 UTC
As mentioned on telegram, we can create a new color palette that contains various chart color palettes in it, including the old one, some new ones from various sources and the new default one whenever its finalized.

Patch - https://gerrit.libreoffice.org/37888

Call for Submissions
http://nabble.documentfoundation.org/Chart-Colors-td4214948.html
Comment 11 Heiko Tietze 2017-05-22 07:15:45 UTC
(In reply to Yousuf Philips (jay) from comment #10)
> As mentioned on telegram, we can create a new color palette that contains
> various chart color palettes in it, including the old one, some new ones
> from various sources and the new default one whenever its finalized.
> 
> Patch - https://gerrit.libreoffice.org/37888
> 
> Call for Submissions
> http://nabble.documentfoundation.org/Chart-Colors-td4214948.html

Not sure about legal issues calling colors "Excel 2010".
Comment 12 Yousuf Philips (jay) 2017-05-22 17:39:32 UTC
(In reply to Heiko Tietze from comment #11)
> Not sure about legal issues calling colors "Excel 2010".

We use "Excel 2007-2013 XML" in the save as dialog in Calc, but lets change it to "MS Office 2010" as the chart colors are used in any MSO app.
Comment 13 Commit Notification 2017-05-27 21:06:15 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5a5864f5eec6761a8c20f4b77bac8bd83c7cec84

tdf#106534 New color palette with various charts palettes

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2017-06-03 14:41:50 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6950cbe233b72e87f0cbbeaf8903d5c8caa7bf7d&h=libreoffice-5-4

tdf#106534 New color palette with various charts palettes

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.